[gdal-dev] XY Tolerance = 0 when creating layer in region settings with comma decimal separator

Karen M kbmeinstein at rothwellgroup.com
Thu Sep 2 13:03:10 PDT 2021

Hi All,

I'm using the C# bindings in gdal version
release-1900-x64-gdal-2-4-3-mapserver-7-4-2.  When the operating system
region settings are set to regions that uses a comma as the decimal
separator and I use datasource.CreateLayer() to create a new file
geodatabase layer, the resulting feature class has XY Tolerance = 0 when I
use the layer in ArcGIS Pro.  When I use a region that uses decimal points,
the XY Tolerance is non-zero (which is correct).

I've tried using the option "XYTOLERANCE=0.000000008983153" in
CreateLayer(), but I still get XY Tolerance = 0.  This is causing some
editing problems in ArcGIS Pro, and I need the software to work with
various region settings, not just ones that use decimal points.  Anyone
have any suggestions how to fix this?


*Karen Meinstein*
Product Support
kbmeinstein at rothwellgroup.com | 303-261-8107 x 15

<http://www.rothwellgroup.com/>[image: The Rothwell Group, L.P.]

RothwellGroup.com <http://rothwellgroup.com/> | PaleoGIS.com
<http://paleogis.com/> | BizRun.com <http://www.bizrun.com/>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/gdal-dev/attachments/20210902/e1ddcf24/attachment.html>

More information about the gdal-dev mailing list