[GeoNode-devel] Geonode 2.4 on Ubuntu 16.04 - unmet dependencies

Jonathan Doig j.doig at unsw.edu.au
Thu Nov 10 14:51:53 PST 2016

Thanks Simone

I followed those instructions – with a few changes – and managed to get Geonode 2.4 installed on Ubuntu 16.04, thanks.

I’ve created Ansible playbooks for the whole thing, may be able to share these if helpful. They’re pretty basic, no error-checking, but they work for me.


From: Simone Dalmasso [mailto:simone.dalmasso at gmail.com]
Sent: Thursday, 3 November 2016 5:33 PM
To: Jonathan Doig
Cc: geonode-devel at lists.osgeo.org
Subject: Re: [GeoNode-devel] Geonode 2.4 on Ubuntu 16.04 - unmet dependencies

not sure that's the issue because the only place geonode 2.5 is available is in the testing ppa moreover the error is that geonode depends on django <=1.7 but the 1.8 is to be installed and I think is because the 1.6 might not be available for xenial https://launchpad.net/ubuntu/+source/python-django.

I would suggest you to go for the manual installation under a virtualenv, the doc is for the 2.4 but the process is very similar http://docs.geonode.org/en/master/tutorials/install_and_admin/geonode_install/index.html

hope this helps

2016-11-03 0:01 GMT+01:00 Jonathan Doig <j.doig at unsw.edu.au<mailto:j.doig at unsw.edu.au>>:
Hi devs

No reply on geonode-users, so I’m trying here.


From: geonode-users [mailto:geonode-users-bounces at lists.osgeo.org<mailto:geonode-users-bounces at lists.osgeo.org>] On Behalf Of Jonathan Doig
Sent: Wednesday, 2 November 2016 5:05 PM
To: geonode-users at lists.osgeo.org<mailto:geonode-users at lists.osgeo.org>
Subject: [GeoNode-users] Geonode 2.4 on Ubuntu 16.04


I’m trying to install Geonode 2.4 on Ubuntu 16.04, being new to both.

I’m stepping through the OSGeoLive install_geonode.sh script following this advice from Angelos Tzotsos on Aug 18:

>  GeoNode 2.4 works fine on Xenial.

>  The Debian packaging has been updated accordingly.

>  Please check the OSGeoLive install script to find out how to install:

>  https://github.com/OSGeo/OSGeoLive/blob/master/bin/install_geonode.sh

However line 50:
apt-get --assume-yes install python-geonode libapache2-mod-wsgi curl

Is giving trouble:
The following packages have unmet dependencies:
python-geonode : Depends: python-django (<= 1.7) but 1.8.7-1ubuntu5.2 is to be installed
                  Recommends: transifex-client but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I think it’s because python-geonode is v2.5.5 which uses django 1.8, where I want v2.4 which needs django 1.6.

I tried specifying a geonode version: --target_release ‘2.4*’ or /release or /stable but nothing was found.

Advice please.


Jonathan Doig
Software Engineer – Spatial Systems
City Futures Research Centre
UNSW Built Environment

geonode-devel mailing list
geonode-devel at lists.osgeo.org<mailto:geonode-devel at lists.osgeo.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20161110/f9c6d90b/attachment-0001.html>

More information about the geonode-devel mailing list