[GeoNode-devel] Backup and restore of Geonode 2.4

Jonathan Doig j.doig at unsw.edu.au
Wed May 16 00:14:57 PDT 2018


Transferring our Geonode 2.4 to AWS. How to backup the content and restore to the new instance?

The doco and past threads point to builds using Geoserver 2.9 or later, but Geonode 2.4 has Geoserver 2.7.4.

I've tried pg_dump:
/usr/bin/pg_dump geonode --port=5432 --username=postgres --format=t > geonode_ dump.tar
/usr/bin/pg_dump geonode_data --port=5432 --username=postgres --format=t > geonode_data_dump.tar

Also tarred and transferred the uploaded subfolder

That restores OK up to a point:

  *   geonode lists layers, maps, documents, people, groups
  *   psql shows the tables are created and have records, both in geonode and geonode_data

But Geoserver reports 0 layers, so maps in Geonode show as pink broken images ("Could not find layer").

Tried 'python manage.py updatelayers', but it updated 0 layers.

There's no "find_geoserver_broken_layers" command in manage.py in Geonode 2.4.

Do I also need to transfer the content of the GEOSERVER_DATA folder? Trying that next...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180516/1ef1254c/attachment.html>

More information about the geonode-devel mailing list