[GeoNode-devel] Backup and restore of Geonode 2.4

Jonathan Doig j.doig at unsw.edu.au
Thu May 17 01:54:48 PDT 2018

Thanks so much Dave and Faneva

I may have to park this for a few weeks, but I’ll use both your contributions when I come back to it.


From: geonode-devel [mailto:geonode-devel-bounces at lists.osgeo.org] On Behalf Of ANDRIAMIADANTSOA Fanevanjanahary
Sent: Wednesday, 16 May 2018 8:46 PM
To: Dave Kennewell <davekennewell at gmail.com>
Cc: geonode-devel <geonode-devel at lists.osgeo.org>; jondoig [via OSGeo.org] <ml+s1560n5364518h73 at n6.nabble.com>
Subject: Re: [GeoNode-devel] Backup and restore of Geonode 2.4

Hello Jonathan,

Maybe this document can help you https://training.geonode.geo-solutions.it/002_install_and_admin/003_geonode_update/26_to_27/index.html#update-from-geonode-2-6-3-to-geonode-2-7


On Wed, May 16, 2018 at 10:35 AM, Dave Kennewell <davekennewell at gmail.com<mailto:davekennewell at gmail.com>> wrote:
Hi Jonathan,

This script is originally for 2.0 but it covered everything I needed to backup 2.4. I used a tweaked version many (many) times lol.


Hope that helps a bit.


On 16 May 2018 at 11:15, jondoig [via OSGeo.org] <ml+s1560n5364518h73 at n6.nabble.com<mailto:ml+s1560n5364518h73 at n6.nabble.com>> wrote:

Transferring our Geonode 2.4 to AWS. How to backup the content and restore to the new instance?

The doco and past threads point to builds using Geoserver 2.9 or later, but Geonode 2.4 has Geoserver 2.7.4.

I’ve tried pg_dump:
/usr/bin/pg_dump geonode --port=5432 --username=postgres --format=t > geonode_ dump.tar
/usr/bin/pg_dump geonode_data --port=5432 --username=postgres --format=t > geonode_data_dump.tar

Also tarred and transferred the uploaded subfolder

That restores OK up to a point:

  *   geonode lists layers, maps, documents, people, groups
  *   psql shows the tables are created and have records, both in geonode and geonode_data

But Geoserver reports 0 layers, so maps in Geonode show as pink broken images (“Could not find layer”).

Tried ‘python manage.py updatelayers’, but it updated 0 layers.

There’s no “find_geoserver_broken_layers” command in manage.py in Geonode 2.4.

Do I also need to transfer the content of the GEOSERVER_DATA folder? Trying that next…


geonode-devel mailing list
[hidden email]<http://user/SendEmail.jtp?type=node&node=5364518&i=0>

If you reply to this email, your message will be added to the discussion below:
To unsubscribe from GeoNode, click here<http://osgeo-org.1560.x6.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=5185390&code=ZGF2ZWtlbm5ld2VsbEBnbWFpbC5jb218NTE4NTM5MHwtOTI1NjEyMTk0>.

geonode-devel mailing list
geonode-devel at lists.osgeo.org<mailto:geonode-devel at lists.osgeo.org>

Phone: +261 33 80 555 56
Mob: +261 34 14 555 56
Linkedin: https://www.linkedin.com/in/fanevanjanahary<https://www.linkedin.com/in/fanevanjanahary-andriamiadantsoa-52254bb6>
Twitter: @fanevanjanahry

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180517/ff979ed0/attachment-0001.html>

More information about the geonode-devel mailing list