[GeoNode-devel] Problems Running GeoNode's Test Suite

Travis Brundage travislbrundage at gmail.com
Thu Oct 31 12:13:01 PDT 2019

Hey all,

So I have been struggling a bit with figuring out how to run GeoNode's test
suite properly, and I've also run into multiple problems. I am still not
entirely clear on what I am supposed to be doing to run GeoNode's tests,
but here is what I have done:

In .env: SET_DOCKER_ENV=development

Starting GeoNode docker: docker-compose -f docker-compose.async.yml -f
docker-compose.development.yml up -d

Configuring the system for running tests:
1. Install python 2.7 on the system. Checking python version is 2.7.x:
python --version
2. Create a python virtual environment for GeoNode dev
2a. Install virtualenv: sudo apt-get install python-virtualenv
2b. Create Python2.7 virutalenv: virtualenv -p `which python2.7` geonode-env
2c. Activate the environment: source geonode-env/bin/activate
3. In geonode/ install the requirements: pip install -r requirements.txt
4. Configure GDAL bindings (reference
    sudo add-apt-repository ppa:ubuntugis/ppa && sudo apt-get update
    sudo apt-get update
    sudo apt-get install gdal-bin
    sudo apt-get install libgdal-dev
    export CPLUS_INCLUDE_PATH=/usr/include/gdal
    export C_INCLUDE_PATH=/usr/include/gdal
    pip install GDAL==2.4.2

Finally, running tests: coverage run --branch --source=geonode manage.py
test <geonode.app.tests> --noinput
(replacing with app I want to test)

Btw, I added this to our running document of notes for GeoNode, but please
point out if I am doing something incorrectly:

For a while this was mostly working (just slow, some problems in the setUp
causing that). However, now I have run into a blocking issue. I don't know
what I have done or changed other than pulling recent commits. Celery is
complaining about an improperly configured file-system backend.

    ImproperlyConfigured: The configured path for the file-system backend
does not work correctly, please make sure that it exists and has the
correct permissions.

Full stack trace:

Every test I run has the same result. Anyone have pointers for what this
might mean is wrong with my GeoNode?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20191031/2211ddee/attachment.html>

More information about the geonode-devel mailing list