[GeoNode-devel] [Docker][SPCGeonode] Questions

Francesco Frassinelli francesco.frassinelli at nina.no
Thu Feb 6 06:08:48 PST 2020

Hi João,
If the URL was built correctly in a older version, it is a regression indeed and a but report containing information about which version was producing the correct URL (the latest known one) and which one is not (the first known one) is appreciated. It would be nice to easily replicate that behaviour using a script, so a git bisect can be used to spot the faulty commit.


From: geonode-devel <geonode-devel-bounces at lists.osgeo.org> On Behalf Of João Gaspar
Sent: Wednesday, December 25, 2019 9:06 PM
To: geonode-devel at lists.osgeo.org
Subject: [GeoNode-devel] [Docker][SPCGeonode] Questions

first of all, let me congratulate the excellent job with this configuration.

I install the last version of SPCGeonode with docker in Kubuntu following your guide.
Everything was install has expected but now I found some issues that I want to clarify before to report as a bug.

Actual problems:
Adding a remote service from a QGIS Server connection, read the layers but don't project the layer and after the harvest assumes a different URL.
So if I do http://siteURL/qgis/qgis_mapserv.fcgi.exe?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities&MAP=repo/project.qgs after the harvest the URL is changed to

I tested this in a previous version of geonode and works fine.

After trying a lot of times without success the adding remote service I think to add wms service using Backoffice GeoServer. After try to add the Layers from the QGIS Server connection I lose the ability to see the layers with a java error  Then I try to delete the store but give me the same error message when I try to see the layers. I test using geoserver/rest/  and I have the following error: Don't know how to handle resource WMTSLayerInfoImpl[layer]

So the layer is in ESPG:32629
PROJCS["WGS 84 / UTM zone 29N",GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID["WGS 84",6378137,298.257223563,AUTHORITY["EPSG","7030"]],AUTHORITY["EPSG","6326"]],PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]],UNIT["degree",0.0174532925199433,AUTHORITY["EPSG","9122"]],AUTHORITY["EPSG","4326"]],PROJECTION["Transverse_Mercator"],PARAMETER["latitude_of_origin",0],PARAMETER["central_meridian",-9],PARAMETER["scale_factor",0.9996],PARAMETER["false_easting",500000],PARAMETER["false_northing",0],UNIT["metre",1,AUTHORITY["EPSG","9001"]],AXIS["Easting",EAST],AXIS["Northing",NORTH],AUTHORITY["EPSG","32629"]]

And the qgis server project is in EPSG:4326

I notice that the user projections don't have the ESPG:32629 in the file

/opt/geonode/scripts/spcgeonode/_volume_geodatadir/user_projections/epsg.properties This can be the problem?

My questions:

When do I want to do changes what is the correct action?

Sudo docker exec -it spc_container /bin/bash to enter in the container? If yes, I tried but I have the permission denied.


I change the directory inside Scripts/SPCgeonode and do the build? If yes, what is the right docker build command?

Thank you for your time.

P.S: I'm available to help in this SPCGeonode Docs and try to clarify some possible steps or explain the purposes of each folder and docker commands. For me is a good way to learn and have an official source to look.

Best regards,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20200206/e5760e63/attachment-0001.html>

More information about the geonode-devel mailing list