[GeoNode-users] geonode no maps and layer

Eugenio Trumpy frippe12573 at hotmail.com
Thu Dec 3 07:28:55 PST 2015

Thank you for this suggestion, I correctly add the column, however the problem remains:
layers, maps, documents, people and groups are present (and counted) but not listed
on click to each item.

Other hints? Or I only have to downgrade geonode to 2.4.0 as Simone suggested?



From: alessio.fabiani at geo-solutions.it
Date: Thu, 3 Dec 2015 16:04:02 +0100
Subject: Re: [GeoNode-users] geonode no maps and layer
To: frippe12573 at hotmail.com
CC: geonode-users at lists.osgeo.org

The easiest way to solve it without droppping all your data, is to connect directly to the geonode DB and add the "metadata_uploaded_preserve" column of type boolean to the table "base_resourcebase".
ALTER TABLE base_resourcebase ADD COLUMN metadata_uploaded_preserve boolean;==
GeoServer Professional Services from the experts! Visit
http://goo.gl/NWWaa2 for more information.

Ing. Alessio Fabiani at alfa7691Founder/Technical Lead
GeoSolutions S.A.S.Via Poggio alle Viti 118755054  Massarosa (LU)Italyphone: +39 0584 962313fax:     +39 0584 1660272mob:   +39  331 6233686
Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.
The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.

On Thu, Dec 3, 2015 at 3:48 PM, Eugenio Trumpy <frippe12573 at hotmail.com> wrote:

Hi all,

today I controlled my geonode home page. It seemed to work fine, since the home page
showed 15 layers and 5 maps. However if I click on layers, any layers appears in the list.
The same happens form maps and documents.

I tried to launch updatelayers with any result.
The I re-sync the DB and updatelayers, but no results, only an error:

python manage.py updatelayers
Not enabling BingMaps base layer as a BING_API_KEY is not defined in local_settings.py file.
Stopping process because --ignore-errors was not set and an error was found.
Traceback (most recent call last):
  File "manage.py", line 28, in <module>
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/base.py", line 242, in run_from_argv
    self.execute(*args, **options.__dict__)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/base.py", line 285, in execute
    output = self.handle(*args, **options)
  File "/dati/geonode/geonode/geoserver/management/commands/updatelayers.py", line 108, in handle
  File "/dati/geonode/geonode/geoserver/helpers.py", line 458, in gs_slurp
    "bbox_y1": Decimal(resource.latlon_bbox[3])
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/manager.py", line 154, in get_or_create
    return self.get_queryset().get_or_create(**kwargs)
  File "/usr/local/lib/python2.7/dist-packages/modeltranslation/manager.py", line 341, in get_or_create
    return super(MultilingualQuerySet, self).get_or_create(**kwargs)
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/query.py", line 376, in get_or_create
    return self.get(**lookup), False
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/query.py", line 304, in get
    num = len(clone)
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/query.py", line 77, in __len__
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/query.py", line 857, in _fetch_all
    self._result_cache = list(self.iterator())
  File "/usr/local/lib/python2.7/dist-packages/polymorphic/query.py", line 264, in iterator
    for o in base_iter:
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/query.py", line 220, in iterator
    for row in compiler.results_iter():
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/sql/compiler.py", line 713, in results_iter
    for rows in self.execute_sql(MULTI):
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/sql/compiler.py", line 786, in execute_sql
    cursor.execute(sql, params)
  File "/usr/local/lib/python2.7/dist-packages/django/db/backends/util.py", line 69, in execute
    return super(CursorDebugWrapper, self).execute(sql, params)
  File "/usr/local/lib/python2.7/dist-packages/django/db/backends/util.py", line 53, in execute
    return self.cursor.execute(sql, params)
  File "/usr/local/lib/python2.7/dist-packages/django/db/utils.py", line 99, in __exit__
    six.reraise(dj_exc_type, dj_exc_value, traceback)
  File "/usr/local/lib/python2.7/dist-packages/django/db/backends/util.py", line 53, in execute
    return self.cursor.execute(sql, params)
Exception: ('Failed to process reg2001_s_wgs84utm33', ProgrammingError('column base_resourcebase.metadata_uploaded_preserve does not exist\nLINE 1: ...ometry", "base_resourcebase"."metadata_uploaded", "base_reso...\n                                                             ^\n',))

Afterwords I updated also the geonode code from git, re-sync DB and updatelayer, but again the same error.
I checked the DB, the maps and layer are correctly described in the rows.

I think it is a connection problem between geonode and postgresql/postgis. Isn't it? If yes, how can I solve?

Thanks in advance



geonode-users mailing list

geonode-users at lists.osgeo.org


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20151203/3e1f8750/attachment.html>

More information about the geonode-users mailing list