[GeoNode-users] Problems after Upgrade

Christian Willmes christian.willmes at googlemail.com
Tue Mar 17 02:03:41 PDT 2015


im running a geonode 2.4beta from the testing Ubuntu ppa.

After a apt-get update/upgrade this morning, I can't get geonode to restart.

I have this (scary) message in my logs:

[Tue Mar 17 03:59:59.676955 2015] [:error] [pid 1671:tid 
139799543056128] [remote] ImproperlyConfigured: Cannot 
determine PostGIS version for database "geonode_data". GeoDjango 
requires at least PostGIS version 1.3. Was the database created from a 
spatial database template?

Any hints, how to solve this?

Interesting though, that on commandline 'geonode updatelayers' seems to 
execute without errors. But it dit not solve the above problem.


More information about the geonode-users mailing list