[GeoNode-users] segmentation fault while I save a map

Eugenio Trumpy frippe12573 at hotmail.com
Thu Oct 29 09:37:58 PDT 2015


as I previous stated, my geonode installation in test mode works fine (I have no error on saving maps and whatever).
So that I tried to re-modify the config files to run geonode in a deployment mode, but I got the same error.

Since the test mode (run geonode at port 8000 by using internal geoserver [placed within geonode directory and served by jetty] and internal DB) I guess my problem could be related to both my external DB and geoserver application and how they are connected with geonode (django).
Actually it seems I have no problem with geonode (django) DB, the table were created and updated once I added the layer or the documents, and so on.
The geonode_data spatial db is still empty. I believed it would have populated once a user upload a spatial dataset, or am I wrong? The spatial layers are actually stored in the geoserver data directory which stay in the tomcat container.

The connection between geoserver and geonode seems to work regarding the layer but not on the maps.

However considering the modifications on the config files from the version used on the well running test mode(TM) and deployment mode(DM), I have:

in geonode/local_setting.py

DM: SITEURL = "http://my_server_name"
TM: SITEURL = "http://my_server_name:8000/"

TM:  'LOCATION' : 'http://my_server_name:8080/geoserver/',
TM: 'PUBLIC_LOCATION' : 'http://my_server_name:8080/geoserver/',
 DM:     'LOCATION' : 'http://my_server_name:8082/geoserver/',
 DM:    'PUBLIC_LOCATION' : 'http://my_server_name:8082/geoserver/',

in tomcat7/webapp/geoserver/WEB-INF/web.xml

TM: <context-param><param-name>GEONODE_BASE_URL</param-name><param-value>http://my_server_name:8000/</param-value></context-param>

DM: <context-param><param-name>GEONODE_BASE_URL</param-name><param-value>http://my_server_name/</param-value></context-param>

in tomcat7/webapp/geoserver/data/security/auth/geonodAuthProvider/config.xml

TM: <baseUrl>http://my_server_name:8000/</baseUrl>
DM: <baseUrl>http://my_server_name/</baseUrl>

Is there something wrong in the DM configurations?

Since the test mode was running I think I am quite close to the solution....I hope...

Hints are very appreciated...



From: frippe12573 at hotmail.com
To: ingenieroariel at gmail.com
CC: geonode-users at lists.osgeo.org
Subject: RE: [GeoNode-users] segmentation fault while I save a map
Date: Thu, 29 Oct 2015 16:13:33 +0100

Eventually, I'm able to run geonode without any errors (including saving maps) by using the development mode (I guess),
I mean running the server at port 8000.

Now I need to find out what is my problem in the deployment configuration.


From: ingenieroariel at gmail.com
Date: Wed, 28 Oct 2015 11:33:40 -0500
Subject: Re: [GeoNode-users] segmentation fault while I save a map
To: frippe12573 at hotmail.com
CC: geonode-users at lists.osgeo.org

Run the site with manage.py runserver (and fixe ip accordingly) and then try to save.
This time you would get a traceback on the terminal that mae be easier to debug.
On Wed, Oct 28, 2015 at 11:17 AM, Eugenio Trumpy <frippe12573 at hotmail.com> wrote:

Dear all,

unfortunately I am here again with the same problem I had 2 or 3 weeks ago.
The main problem is when I save a map I got a 500 server error, which is referred to the following line in the apache2 error log:

[Wed Oct 28 16:50:10.835817 2015] [core:notice] [pid 18289] AH00052: child pid 18734 exit signal Segmentation fault (11)

Actually the map is not saved, however it appears in the map list, without the thumb. 
If I click on such map I have the page error:

IndexError at /maps/6
  list index out of range

      Request Method:
      Request URL:

      Django Version:

      Exception Type:

      Exception Value:
      list index out of range

      Exception Location:
      /dati/geonode/geonode/utils.py in viewer_json, line 265

      Python Executable:
      Python Version:
      Python Path:
      Server time:
      Wed, 28 Oct 2015 10:50:54 -0500
As you suggested I tested an installation on vagrant box (ubuntu server 14.04, apache2.4.7, tomcat7 and postgresql9.3, all installed as packages). This test works fine, I had not the error on saving maps.

So I updated my server, now I have:
ubuntu 14.04, apache 2.4.7,  postgresql9.3+postgis2.1 installed as packages and tomcat7 installed manually.
After the syncdb problem (solved) I installed geonode.
Everything seems to work fine: I'm able to upload layers, I'm able to create the maps even choosing the layers uploaded, but I got again the same ewrror on saving maps.

Here I attached the local_setting.py file and the apache2 virtualhost config.
During the configuration I also follow the instructions regarding 'Configuring GeoServer' which is in the end, inserting the context param GEONODE_BASE_URL and the URL (my_server_name) in web.xml and I put my_server_name in the config.xml as indicated.

Actually, after many many attempt I'm giving up hope...

thanks for the possible hints



geonode-users mailing list

geonode-users at lists.osgeo.org


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20151029/5d135de2/attachment.html>

More information about the geonode-users mailing list