[GeoNode-users] post-installation issues

Simone Dalmasso simone.dalmasso at gmail.com
Tue Sep 29 08:18:44 PDT 2015

The list seems ok.
You can try to install ipdb https://pypi.python.org/pypi/ipdb and add
import ipdb; ipdb.set_trace()
at line 264. then go one step down with "n" and see what's wrong there. You
can access the variables and see which lookup fails at line 266. It can be

For geoserver, it has an admin user that is used by geonode and no others
should use it. For security reasons it is recommended to change it's
credentials in settings and the geoserver users page. but normal
administrators will always use their geonode accounts to access geoserver.

2015-09-29 16:55 GMT+02:00 Eugenio Trumpy <frippe12573 at hotmail.com>:

> Hi,
> I had these lines:
> >>> from django.conf import settings
> >>> settings.MAP_BASELAYERS
> [{'source': {'url': 'http://my_server_name/geoserver2/wms', 'restUrl':
> '/gs/rest', 'ptype': 'gxp_wmscsource'}}, {'group': 'background', 'args':
> ['No background'], 'visibility': False, 'source': {'ptype':
> 'gxp_olsource'}, 'fixed': True, 'type': 'OpenLayers.Layer'}, {'group':
> 'background', 'name': 'mapnik', 'visibility': False, 'source': {'ptype':
> 'gxp_osmsource'}, 'fixed': True, 'type': 'OpenLayers.Layer.OSM'},
> {'source': {'ptype': 'gxp_mapquestsource'}, 'group': 'background', 'name':
> 'osm', 'visibility': True}, {'source': {'ptype': 'gxp_mapquestsource'},
> 'group': 'background', 'name': 'naip', 'visibility': False}, {'source':
> {'ptype': 'gxp_bingsource'}, 'fixed': True, 'group': 'background', 'name':
> 'AerialWithLabels', 'visibility': False}, {'source': {'ptype':
> 'gxp_mapboxsource'}}]
> >>>
> Is that correct?
> Regarding the second question, I see geoserver keeps the user from django,
> I don't understand if I have to change the user of geoserver in settings.py
> and local_settings.py, inserting the same of django, or I should modify
> something on geoserver, or nothing?
> Best
> E.
> ------------------------------
> From: simone.dalmasso at gmail.com
> Date: Tue, 29 Sep 2015 16:41:15 +0200
> Subject: Re: [GeoNode-users] post-installation issues
> To: frippe12573 at hotmail.com
> CC: geonode-users at lists.osgeo.org
> Eugenio to debug you can open a python in your virtualenv with
> $ python manage.py shell
> then try to import the settings with
> >>> from django.conf import settings
> then see how the MAP_BASELAYERS looks like with
> >>> settings.MAP_BASELAYERS
> for the second question the answer is yes, geoserver shares the same users
> as geonode although it keeps a default admin password that you change both
> in the settings and the geoserver users page.
> 2015-09-29 16:37 GMT+02:00 Eugenio Trumpy <frippe12573 at hotmail.com>:
> Dear all,
> I completed the installation of geonode
> *vs 2.4.dev20150908094256,*I even solved the problem on geoserver and it
> seems to run well.
> I set a geoserver from my organization as external service and
> I'm able to see the layers available. I can see the map of the layer
> and I can use them to prepare maps.
> I tried also to upload a document, and even this function runs well.
> My main problem is on map saving, this operation gives me the 500 internal
> server error.
> By the way the map appears on the list of maps.
> Checking the db (postgres) I see in the maps table the new record,
> however from the map's list I cannot visualize such map, and a new error
> page
> with yellow narrow appears. This page contains many statements*,* these
> three lines
> give an hint on the possible problem:
> Exception Type: IndexError Exception Value:
> list index out of range
> Exception Location: /dati/geonode/geonode/utils.py in viewer_json, line
> 266
> This is my first issue, I got a suggestion (here in the mailing list) to
> debug by python
> console geonode, but unfortunately I don't know how to start.
> Suggestions?
> Another question, might be related to the previous problem, is on
> geoserver authentication:
> I didn't give any password during the installation, and in
> local_setting.py and setting.py
> I see that geoserver has the classical administrator credentials
> (admin,geoserver).
> However if I use the link to geoserver from the user context menu (in the
> geonode website)
> I see the geoserver home page already logged in, but the user logged is
> not admin,
> but the superuser of django. Is that right? Have I set th geoserver
> credential somewhere?
> Thanks for now,
> best regards
> Eugenio
> _______________________________________________
> geonode-users mailing list
> geonode-users at lists.osgeo.org
> http://lists.osgeo.org/cgi-bin/mailman/listinfo/geonode-users
> --
> Simone

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20150929/60bd29a1/attachment-0001.html>

More information about the geonode-users mailing list