[GeoNode-users] post-installation issues

Eugenio Trumpy frippe12573 at hotmail.com
Tue Sep 29 08:51:59 PDT 2015

I have problems on using ipdb. I installed it by using easy_install,
then I launched the python console: python manage.py shell
after that I tried to import ipdb and ipdb.set_trace()
but something went wrong:
>>> import ipdb; ipdb.set_trace()
Traceback (most recent call last):
  File "<console>", line 1, in <module>
  File "/usr/local/lib/python2.7/dist-packages/ipdb-0.8.1-py2.7.egg/ipdb/__init__.py", line 16, in <module>
    from ipdb.__main__ import set_trace, post_mortem, pm, run, runcall, runeval, launch_ipdb_on_exception
  File "/usr/local/lib/python2.7/dist-packages/ipdb-0.8.1-py2.7.egg/ipdb/__main__.py", line 27, in <module>
    import IPython
  File "/usr/local/lib/python2.7/dist-packages/ipython-4.0.0-py2.7.egg/IPython/__init__.py", line 47, in <module>
    from .core.application import Application
  File "/usr/local/lib/python2.7/dist-packages/ipython-4.0.0-py2.7.egg/IPython/core/application.py", line 24, in <module>
    from IPython.core import release, crashhandler
  File "/usr/local/lib/python2.7/dist-packages/ipython-4.0.0-py2.7.egg/IPython/core/crashhandler.py", line 28, in <module>
    from IPython.core import ultratb
  File "/usr/local/lib/python2.7/dist-packages/ipython-4.0.0-py2.7.egg/IPython/core/ultratb.py", line 116, in <module>
    from IPython.utils import path as util_path
  File "/usr/local/lib/python2.7/dist-packages/ipython-4.0.0-py2.7.egg/IPython/utils/path.py", line 19, in <module>
    from IPython.utils.process import system
  File "/usr/local/lib/python2.7/dist-packages/ipython-4.0.0-py2.7.egg/IPython/utils/process.py", line 19, in <module>
    from ._process_posix import system, getoutput, arg_split, check_pid
  File "/usr/local/lib/python2.7/dist-packages/ipython-4.0.0-py2.7.egg/IPython/utils/_process_posix.py", line 24, in <module>
    import pexpect
ImportError: No module named pexpect

Something is still missing?


From: simone.dalmasso at gmail.com
Date: Tue, 29 Sep 2015 17:18:44 +0200
Subject: Re: [GeoNode-users] post-installation issues
To: frippe12573 at hotmail.com; geonode-users at lists.osgeo.org

The list seems ok. You can try to install ipdb https://pypi.python.org/pypi/ipdb and addimport ipdb; ipdb.set_trace()at line 264. then go one step down with "n" and see what's wrong there. You can access the variables and see which lookup fails at line 266. It can be either keys[-1]

For geoserver, it has an admin user that is used by geonode and no others should use it. For security reasons it is recommended to change it's credentials in settings and the geoserver users page. but normal administrators will always use their geonode accounts to access geoserver.
2015-09-29 16:55 GMT+02:00 Eugenio Trumpy <frippe12573 at hotmail.com>:


I had these lines:
>>> from django.conf import settings
>>> settings.MAP_BASELAYERS
[{'source': {'url': 'http://my_server_name/geoserver2/wms', 'restUrl': '/gs/rest', 'ptype': 'gxp_wmscsource'}}, {'group': 'background', 'args': ['No background'], 'visibility': False, 'source': {'ptype': 'gxp_olsource'}, 'fixed': True, 'type': 'OpenLayers.Layer'}, {'group': 'background', 'name': 'mapnik', 'visibility': False, 'source': {'ptype': 'gxp_osmsource'}, 'fixed': True, 'type': 'OpenLayers.Layer.OSM'}, {'source': {'ptype': 'gxp_mapquestsource'}, 'group': 'background', 'name': 'osm', 'visibility': True}, {'source': {'ptype': 'gxp_mapquestsource'}, 'group': 'background', 'name': 'naip', 'visibility': False}, {'source': {'ptype': 'gxp_bingsource'}, 'fixed': True, 'group': 'background', 'name': 'AerialWithLabels', 'visibility': False}, {'source': {'ptype': 'gxp_mapboxsource'}}]

Is that correct?

Regarding the second question, I see geoserver keeps the user from django, I don't understand if I have to change the user of geoserver in settings.py and local_settings.py, inserting the same of django, or I should modify something on geoserver, or nothing?


From: simone.dalmasso at gmail.com
Date: Tue, 29 Sep 2015 16:41:15 +0200
Subject: Re: [GeoNode-users] post-installation issues
To: frippe12573 at hotmail.com
CC: geonode-users at lists.osgeo.org

Eugenio to debug you can open a python in your virtualenv with $ python manage.py shellthen try to import the settings with>>> from django.conf import settingsthen see how the MAP_BASELAYERS looks like with>>> settings.MAP_BASELAYERS

for the second question the answer is yes, geoserver shares the same users as geonode although it keeps a default admin password that you change both in the settings and the geoserver users page.
2015-09-29 16:37 GMT+02:00 Eugenio Trumpy <frippe12573 at hotmail.com>:

Dear all,

I completed the installation of geonode vs 2.4.dev20150908094256,
I even solved the problem on geoserver and it seems to run well.
I set a geoserver from my organization as external service and 
I'm able to see the layers available. I can see the map of the layer 
and I can use them to prepare maps.
I tried also to upload a document, and even this function runs well.
My main problem is on map saving, this operation gives me the 500 internal server error.
By the way the map appears on the list of maps.
Checking the db (postgres) I see in the maps table the new record,
however from the map's list I cannot visualize such map, and a new error page
with yellow narrow appears. This page contains many statements, these three lines
give an hint on the possible problem:
Exception Type:

      Exception Value:
      list index out of range

      Exception Location:
      /dati/geonode/geonode/utils.py in viewer_json, line 266
This is my first issue, I got a suggestion (here in the mailing list) to debug by python
console geonode, but unfortunately I don't know how to start.

Another question, might be related to the previous problem, is on geoserver authentication:
I didn't give any password during the installation, and in local_setting.py and setting.py
I see that geoserver has the classical administrator credentials (admin,geoserver).
However if I use the link to geoserver from the user context menu (in the geonode website)
I see the geoserver home page already logged in, but the user logged is not admin,
but the superuser of django. Is that right? Have I set th geoserver credential somewhere?

Thanks for now,

best regards



geonode-users mailing list

geonode-users at lists.osgeo.org



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20150929/2d17c17d/attachment.html>

More information about the geonode-users mailing list