[GeoNode-users] Database and user "geonode" do not exist after apt-get installation [fixed]

Gi Petrak gkpetrak at gmail.com
Wed Feb 1 07:06:16 PST 2017

I 'd like to post an issue that I had with apt-get Installation of GeoNode
and I fixed with the hope of helping someone else with the same problem.
After creating a clean and fresh Ubuntu 14.04 remote VM, I installed
geonode with apt-get:

sudo add-apt-repository ppa:geonode/stable
sudo apt-get update
sudo apt-get install geonode

But when I executed the following commands:
geonode createsuperuser
sudo geonode-updateip

I had errors like:
2017-01-31 22:15:58 EET FATAL:  password authentication failed for user
2017-01-31 22:15:58 EET DETAIL:  Connection matched pg_hba.conf line 94:
2017-01-31 22:54:31 EET FATAL:  role "user" does not exist
2017-01-31 22:54:49 EET FATAL:  database "geonode" does not exist

So, I realized that geonode user and database didn't exist. Thus, I
followed the custom procedure of creating GeoNode DB:

and finally I ran: sudo python manage.py syncdb -noinput

After these steps, problem solved.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20170201/160feaf9/attachment.html>

More information about the geonode-users mailing list