[GeoNode-users] Problem uploading raster file

Stefano.LUONI at ext.ec.europa.eu Stefano.LUONI at ext.ec.europa.eu
Wed Nov 8 07:48:16 PST 2017


I currently have issues with GeoTiff raster files: after uploading from GeoNode, the layer page displays an empty map. Looking from GeoServer admin website, I can see the layer it's disabled, because no SRS is detected; the only way to enable the layer is to manually set SRS.
After enabling the layer, this is visibile from GeoNode, but it is not centered in the map, like the bounds are not correctly computed; the layer preview from GeoServer is fine though.
This is happening on a 2.6.3 installation (standard deployment), with GeoServer 2.9; I tried using both open-jdk and Oracle Java8 with the same result.
The same raster file is uploaded correctly on a development installation (GeoNode 2.9, Geoserver 2.12).

You can find an extraction of GeoSever log attached to this email; it contains several errors, like

ERROR [geoserver.rest] - No such datastore: geonode,floodmapeu_rp200y
ERROR [geoserver.rest] - No such coverage store: geonode,floodmapeu_rp200y
ERROR [geoserver.rest] - No such wms store: geonode,floodmapeu_rp200y
ERROR [geoserver.rest] - No such style: floodmapeu_rp200y
ERROR [geoserver.ows] -
org.geoserver.platform.ServiceException: Could not find layer geonode:floodmapeu_rp200y

I guess something is wrong with my GeoServer installation, but I cannot say how.

You may download the raster file from this link: https://drive.google.com/file/d/1u2iUD4Gf_QZKpjW0nAWNatbR6NxkU6Ni/view?usp=sharing

Stefano Luoni

External consultant for the European Commission (GFT Italia)

European Commission
Joint Research Centre – JRC.E.1
Disaster Risk Management Unit
Building 26b | Via E.Fermi 2749, I-21027 Ispra (VA) Italy, TP 266
Tel: +39 033278 9451
Email: stefano.luoni at ext.jrc.ec.europa.eu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20171108/bede415c/attachment-0001.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: geoserver_log.txt
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20171108/bede415c/attachment-0001.txt>

More information about the geonode-users mailing list