[GeoNode-users] Problem with authentication between geonode and geoserver after a restore

Maxime Audet-Roberge maximeaudetr at hotmail.com
Tue Mar 17 13:34:04 PDT 2020

Hi Jules,

I had already modified the URIs, both in geonode and geoserver. I tried to delete all the tokens (Access and Grant) and it worked!

Thanks for your help!

De : Jules Grillot <jules.grillot at gmail.com>
Envoyé : 12 mars 2020 04:12
À : Maxime Audet-Roberge <maximeaudetr at hotmail.com>
Cc : geonode-users at lists.osgeo.org <geonode-users at lists.osgeo.org>
Objet : Re: [GeoNode-users] Problem with authentication between geonode and geoserver after a restore

Hi Maxime,

In my case the restore of my geonode instance sets all parameters to default (oauth, theme, monitoring,...).
If it's the same for you, you have to change the "Redirect uris" of GeoServer in GeoNode's Application panel in Administration (http://yourgeonode/fr/admin/oauth2_provider/application/).
The uris as to be the same as the Redirect Url from the "geonode-auth2" authentication filter in Geoserver.

Here is the documentation :

If you want to change the by default URL so the restore don't break the connection between the Geonode and Geoserver you have to change the "redirect uris" in this file :

Hope it helps you,


Le mer. 11 mars 2020 à 18:41, Maxime Audet-Roberge <maximeaudetr at hotmail.com<mailto:maximeaudetr at hotmail.com>> a écrit :
Good day geonode users,

I am trying to restore my geonode instance on a different machine but I have a problem with the authentication between geonode and geoserver. I am using geonode project 2.10.1 and geoserver 2.15.2 on a Ubuntu 18.04 machine.

First, I install geonode and geoserver. At that point, everything is working fine; I can connect to geoserver from my geonode admin account. Then I restore the geoserver data by replacing the geoserver_data directory. Everything is still working fine at that point. The problem occurs when I restore the geonode data; I can no longer login to geoserver from my geonode account. I have this message in the geoserver log:

2020-03-11 17:23:24,700 WARN [geoserver.security] - Error while trying to authenticate to OAuth2 Provider with the following Exception cause:

error="access_denied", error_description="Error requesting access token."

Strangely, I still have access to my data on geonode, I can consult them and display them on a map.

Anybody got any ideas?



geonode-users mailing list
geonode-users at lists.osgeo.org<mailto:geonode-users at lists.osgeo.org>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20200317/9fae3933/attachment.html>

More information about the geonode-users mailing list