[GeoNode-users] R: migration suggestions

Eugenio Trumpy frippe12573 at hotmail.com
Thu Mar 19 09:49:37 PDT 2020

Dear Alessio and list,

I proceed a bit since my last email (2 two days ago).
However, still some trouble remain in the migration process I started to pass from the old geonode2.4 to the master version.

  1.  Geoserver at version 2.16.2 is up and running with the backuped DATA_DIR, set outside geoserver. Solved the 404 error and the I re-publish again the layer from the missing store I mentioned in my previous email.
  2.  I set the wgsi module in apache2. The geonode is served now with the 'allowed_hosts' error. I think the issue could be related to the settings. In the 2.4 version I remember I set SITE_URL, should I set something similar even in this version?
  3.  I created a geonode postgresql empty db, while I restored the backup from that I was using in 2.4 version. How I should populate with the new data-schema the geonode metadata db? I remember there was the command python manage.py --syncdb, does still exist? I tried but I got error.

Any suggestion on point #2 and #3?

Best regards,


Da: Eugenio Trumpy <frippe12573 at hotmail.com>
Inviato: martedì 17 marzo 2020 11:18
A: Alessio Fabiani <alessio.fabiani at geo-solutions.it>
Cc: geonode-users at lists.osgeo.org <geonode-users at lists.osgeo.org>
Oggetto: R: [GeoNode-users] migration suggestions

Dear Alessio,

maybe you remember my request of help dated end of October 2019.
I had, but I still have, to updated geonode 2.4 to the last version and you and Paolo Corti gave me some hints.
Sincerely, I was a bit downhearted, because the procedure didn't seems so easy and quick and even because
I have installed geonode in multi-sites and I have more then 100 layers coming from different sources.

However, I take the occasion of this very strange period for us, to start the migration following your suggestions.
Unfortunately, there are some steps not completely clear and I realised that the installation of geonode changed
not a little since the last version (2.4) I installed.

In the following, I comment among your old lines and I ask you some clarification in blue:

1. Setup a new GeoServer 2.15.2 ( https://build.geo-solutions.it/geonode/geoserver/latest/geoserver-2.15.2.war )

I did it. I downloaded the geoserver-2.16.2 version, I installed it on tomcat8, and I set the GEOSERVER_DATA_DIR outside geoserver,
by using the param in the web.xml, at the end geoserver runs.

2. Transfer the Data Dir from the old GeoServer to the new one (I strongly suggest to backport **only** the workspace, datasets and styles, not the security subsystem)

I ported even the data from the old geoserver to the new GEOSERVER_DATA_DIR. I tranfered the following folder: gwc-layerss, legendsamples, styles, workspace, data
Did I miss something?
I'm able to see geoserver datasets, but not all. 2 stores connected to postgresql are missing. I added them manually, and I'm able to see the publishable layers, but they are more or less 45. Is there a way to publish them in one shot? I even try to do it manually and at the first attempt with the first layer I got this error message: No GeoServerTileLayer named 'geonode:my_layer_name' exists
What does it mean? The layer results available, but if I test it as layer preview I have a http 404 error. The geoserver log reports:
2020-03-17 10:01:50,175 ERROR [gwc.layer] - Error saving tile layer 'geonode:my_layer_name'
java.lang.IllegalArgumentException: TileLayer with same name already exists: geonode:my_layer_name: <LayerInfoImpl-110ff9fd:163f49ebe1b:-1b93>

3. Setup the new GeoNode instance

I followed this documentation: https://docs.geonode.org/en/master/install/core/index.html#geonode-installation
where I proceed not to install in the virtualenv (I don't know how to use it, and I'm installing geonode not in local), I went for the production installation.
The guide is very different with the one I remembered for the version 2.4. Anyway I took the parts useful for me.
Although I have something wrong on geoserver, I proceed in the installation: I installed the dependences, I clone geonode from git,
I installed tomcat8 and geoserver (with an external data_dir), I restore my postgresql database dump (geonode and geonode_data).
I stopped at the webserver. The documentation recommend NGINX, but I have apache2 in my server.
My question is: Can I use Apache2? Is there a documentation to set up apache2 and geonode at this version? or I can follow the same concepts in the documentation we had for the geonode version 2.4. (In this latter case I have already set a virtualhost dedicated to geonode).

I'm at this point. Then I should go on through the geoserver/geonode authorization, right?

4. Run the "updatelayers" management command (see http://docs.geonode.org/en/master/admin/mgmt_commands/index.html#management-command-updatelayers )

still to be carried out

5. Update manually the missing permissions and metadata

still to be carried out - I saw in the online demo that now it is possible to import the metadata xml, which can help me to save time to restore.

Could you clarify the points above mentioned?



Il giorno ven 25 ott 2019 alle ore 16:08 Eugenio Trumpy <frippe12573 at hotmail.com<mailto:frippe12573 at hotmail.com>> ha scritto:
Dear all,

I have a running geonode at version 2.4 dev20160525015826 configured as multisite in a ubuntu server 16.04.6 LTS.
The system administrator suggested me to update the server OS to 18.04.3 LTS for many reasons that are not the topic of this email.

I would like to know if there are suggested procedures to migrate my multisite project, data, ... to a newer version of geonode
(the most update seems to be the vs.2.10).
Just to let you know, for the previous installation I followed the custom installation,
because in the server were already running postgresql, tomcat, and so on...
Moreover, as said, I set the project to be used as multi-sites.

So I need:

  1.  to install a fresh geonode version
  2.  set-up the multi-sites
  3.  dump the data from version 2.4
  4.  load the data in the new version

Any hints or recommendations?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20200319/58b1fd46/attachment.html>

More information about the geonode-users mailing list