[GeoNode-users] Issues with mosaics in GeoNode

Alessio Fabiani alessio.fabiani at geo-solutions.it
Wed May 20 00:59:04 PDT 2020

Hi Paolo,
so you are using GeoNode 2.10.3 and GeoServer 2.15.4 I guess, is that

First of all, as soon as possible update GeoServer with the same version
WAR here
The WARs have been rebuilt recently with some updates of GeoServer
community plugins.

Secondly, are you trying to create the mosaic by using the shapefile index?
Try to create the "datastore.properties" and let GeoServer create the index
on the DB instead.
I recently configured a mosaic with more than 120K granules and it worked
A warning here. When you create the store, the first time, GeoServer will
remain blocked for a long time, until he finished scanning all the
granules. Even if you have some strange page back on the gui or some odd
behavior, don't worry about it.

Finally, there's a method on GeoNode "_invalidate_geowebcache_layer" which
is called when you create a Layer and mostly when you update the style.
Currently, the behavior is trivial, he just invokes the method every time
you update the style. It probably could be improved.

Il giorno ven 15 mag 2020 alle ore 16:56 Paolo Pasquali <
paolo.pasquali at gmail.com> ha scritto:

> Dear all,
> I'm trying to publish two mosaics of about 3500 tiles each in GeoNode.
> Firstly, I've created the shp index and the tile cache on a stand alone
> GeoServer installation without any problem.
> Then I've moved the mosaic tiles and all the cache on a GeoNode 2.10.3
> that I've installed following this documentation:
> https://docs.geonode.org/en/2.10/install/core/index.html#ubuntu-18-04
> 1) The first issue I have encountered is that for both mosaics I get a
> "Too many open files" error from GeoServer. I've both tried to use the old
> shp index and to generate a new one with the GeoNode GeoServer but I always
> get this error.
> I've also disabled the JAI ImageRead (deferred loading) but nothing
> improved.
> I'm wondering why there is a different behaviour between the two
> GeoServers. Maybe I've messed up some gdal library? The gdal version is
> 2.2.3 on Ubuntu 18.04
> 2) The second issue is the Metadata update via GeoNode. I've used
> updatelayers to import the mosaics in GeoNode and then I have used the
> wizard to update the metadata. By updating the metadata, all the tile cache
> has been flushed. Is this the expected behaviour? I understand for small
> rasters may be convenient but in other cases it may not. Is there a way to
> set whether the wizard can flush the cache when updating the metadata?
> Thanks in advance for your help.
> Best,
> Paolo
> _______________________________________________
> geonode-users mailing list
> geonode-users at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/geonode-users



GeoServer Professional Services from the experts! Visit http://goo.gl/it488V
for more information.
Ing. Alessio Fabiani

Founder/Technical Lead

GeoSolutions S.A.S.
Via di Montramito 3/A - 55054  Massarosa (LU) - Italy
phone: +39 0584 962313
fax:     +39 0584 1660272
mob:   +39 331 6233686


Con riferimento alla normativa sul trattamento dei dati personali (Reg. UE
2016/679 - Regolamento generale sulla protezione dei dati “GDPR”), si
precisa che ogni circostanza inerente alla presente email (il suo
contenuto, gli eventuali allegati, etc.) è un dato la cui conoscenza è
riservata al/i solo/i destinatario/i indicati dallo scrivente. Se il
messaggio Le è giunto per errore, è tenuta/o a cancellarlo, ogni altra
operazione è illecita. Le sarei comunque grato se potesse darmene notizia.

This email is intended only for the person or entity to which it is
addressed and may contain information that is privileged, confidential or
otherwise protected from disclosure. We remind that - as provided by
European Regulation 2016/679 “GDPR” - copying, dissemination or use of this
e-mail or the information herein by anyone other than the intended
recipient is prohibited. If you have received this email by mistake, please
notify us immediately by telephone or e-mail.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20200520/473f80a6/attachment-0001.html>

More information about the geonode-users mailing list