[geos-devel] Is it possible to build current CVS versionofgeosbyMinGW

Hisaji Ono hi_ono2001 at ybb.ne.jp
Thu Aug 21 16:33:16 EDT 2003

Thank you for your response, Mr. Vine.

> I do not use Cygwin with the -mno-cygwin switch,  I have a 'separate'
> but complete MingW installation which I run from within a Cygwin Shell
> Most find that MSys is a little easier to use but I haven't tried it
> Both MingW and MSys are available from http://www.mingw.org
> This thread might help
> http://www.cygwin.com/ml/cygwin/2003-02/msg01463.html

Following your way, I did it as follows(geos is geos-20030821).

./autogen.sh #using Cygwin's since Mingw's stopped after error messages

export MINGW=/cygdrive/c/MINGW
export PATH=$MINGW/bin:"$PATH"

./configure --prefix=$MINGW --host=i686-pc-mingw32 # --host=mingw not work


However I've got following a lot of error messages.

g++ -DHAVE_CONFIG_H -I. -I. -I../../source/headers -I../../source/headers -D
_VERSION=1.0 -g -O2 -MT Geometry.lo -MD -MP -MF .deps/Geometry.Tpo -c
pp  -DDLL_EXPORT -DPIC -DPIC -o Geometry.o
In file included from ../headers/graph.h:9,
                 from ../headers/operation.h:12,
                 from Geometry.cpp:6:
../headers/graphindex.h:90: parse error before numeric constant
../headers/graphindex.h:91: missing ';' before right brace
../headers/graphindex.h:92: parse error before `void'
../headers/graphindex.h:93: destructors must be member functions


Geometry.cpp:533: syntax error before `{' token
Geometry.cpp:540: syntax error before `::' token
make[2]: *** [Geometry.lo] Error 1
make[2]: Leaving directory `/home/Administrator/geos-20030821/source/geom'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/Administrator/geos-20030821/source'
make: *** [all-recursive] Error 1

Could you give any suggestion to me>


More information about the geos-devel mailing list