[geos-devel] Compile Problem

Ken Lord kenlord at email.com
Mon Apr 5 15:32:08 EDT 2004

Hello List,

I am unable to compile GEOS, I am a bit of a novice and would
appreciate any help.

A short time into compiling the Hourly CVS Snapshot version of GEOS,
I get the following error message:

In file included from BasicCoordinateList.cpp:30:
../headers/geom.h:316: error: integer constant is too large for
"long" type
../headers/geom.h:585: error: integer constant is too large for
"long" type
make[2]: *** [BasicCoordinateList.lo] Error 1
make[2]: Leaving directory `/usr/src/geos-1.0/source/geom'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/geos-1.0/source'
make: *** [all-recursive] Error 1

I have also tried the 2003/11/06 download, but it fails  when it
finds I have automake 1.7.8 instead of 1.7.3.
For this error I tried running aclocal as it states in the error
message, but then i get the following error when i Make

checking dynamic linker characteristics... GNU/Linux ld.so
./configure: line 18728: syntax error near unexpected token `long'
./configure: line 18728: `PGAC_TYPE_64BIT_INT(long int)'
make: *** [config.status] Error 2

I am running Fedora, with qt3.1, and gcc 3.3.2.

Ken Lord
BGC Engineering Inc.
Vancouver BC

Sign-up for Ads Free at Mail.com

More information about the geos-devel mailing list