[geos-devel] help for installing geos on hpux

Paul Ramsey pramsey at refractions.net
Thu Aug 19 23:59:00 EDT 2004

The error looks like your compiler croaking unpleasantly. I have seen 
this from time to time, but usually on new code and an old compiler. 
(Compiling PostgreSQL 7.4 on OS/X 10.2 does something like this to me.)
I am afraid I have no magic answer. Try a slightly older gcc? Make sure 
your tool chain is consistent (I have found various combinations of 
linkers and compilers on solaris give different results). Try try again.

Luis Hansen wrote:
> Hi everybody
> Im a junior administrator on Unix systems
> I need to install postgresql with options to GEOS and postgis and I get troubles with GEOS  installation the problem is below
> The Unix system is hpux 11.11, I used  Gcc(3.3.3) to compile GEOS and I got  this unexpected  message  when I tried "make"
> CoordinateArrayFiter.lo GEOSException.lo IllegalArgumentException.lo UniqueCoordinateArrayFilter.lo Unsupport
> edOperationException.lo  -L/usr/local/lib /usr/local/lib/libintl.sl -lc 
> ../../libtool[3192]: 25105 Memory fault(coredump)
> gmake[2]: *** [libgeos.la] Error 139
> gmake[2]: Leaving directory `/var/temporal/geos-1.0/source/geom'
> gmake[1]: *** [all-recursive] Error 1
> gmake[1]: Leaving directory `/var/temporal/geos-1.0/source'
> gmake: *** [all-recursive] Error 1
> I used three ways to compile but I always get the same message ......
> 1.- ./configure
> 2.-  CC=c89 CFLAGS=-O2 LIBS=-lposix ./configure
> 3.-  env CPPFLAGS=-I/usr/local/include DFLAGS=-s ./configure
> Other option that I tried was compile with 64 bits (/usr/local/pa64/) succesfully but 
> It is posible works GEOS (64bits)  with posgis and postgres (32bits) and how can I do it???? 
> Sorry for my English! 
> Regards from Argentina!
> I hope that someone can help me

More information about the geos-devel mailing list