[geos-devel] Re: New python/ruby SWIG bindings checked in / Can't build on Mac OSX

Charlie Savage cfis at savagexi.com
Tue Jul 25 02:53:29 EDT 2006

Hi Robert,

On both Linux and Windows with msys, all the generated make files have 
this line:

LIBTOOL = $(SHELL) $(top_builddir)/libtool

This refers to the libtool file that should be in the top level GEOS 
directory.  Is that file missing for you?

Either way, I'm guessing this isn't a SWIG binding issue.  If you're 
missing the libtool file, does that mean you can't compile GEOS either?

I can't help much more on libtool/autoconf/automake etc., but would be 
interested in hearing about your progress with the SWIG bindings on the 
Mac since I don't have one I can test on.



Robert J. Berger wrote:
> I just tried to build the latest CVS on a Macintosh OS X Macbook Pro. I 
> did install swig 1.3.29 and had to run autogen.sh to get the configure 
> files then did the configure line as recommended, configure ran without 
> complaints, then when I tried to build Geos I get:
> % make
> Making all in source
> Making all in algorithm
> source='CGAlgorithms.cpp' object='CGAlgorithms.lo' libtool=yes \
> depfile='.deps/CGAlgorithms.Plo' tmpdepfile='.deps/CGAlgorithms.TPlo' \
> depmode=gcc3 /bin/sh ../../depcomp \
> /bin/sh ../../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I. 
> -I../../source/headers -I../../source/headers/geos 
> -I../../source/headers     -g -O2 -DGEOS_INLINE -Wall -ansi -pedantic 
> -Wno-long-long -c -o CGAlgorithms.lo `test -f 'CGAlgorithms.cpp' || echo 
> './'`CGAlgorithms.cpp
> ../../libtool: ../../libtool: No such file or directory
> I do have libtool, but its in /usr/bin/libtool Not sure why the makefile 
> thinks its in the top_buildir.
> ––––––––––––––––––––––––––––––
> Robert J. Berger - Internet Bandwidth Development, LLC.
> Voice: 408-882-4755 eFax: +1-408-490-2868 
> http://www.ibd.com
> ------------------------------------------------------------------------
> _______________________________________________
> geos-devel mailing list
> geos-devel at geos.refractions.net
> http://geos.refractions.net/mailman/listinfo/geos-devel
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3237 bytes
Desc: S/MIME Cryptographic Signature
Url : http://lists.osgeo.org/pipermail/geos-devel/attachments/20060725/d9d39c4c/smime.bin

More information about the geos-devel mailing list