[geos-devel] Re: Problems with installation of geos on RedHat 9 (third try, i hope this is text)

alex bodnaru alexbodn at 012.net.il
Sat May 20 08:58:41 EDT 2006

hi johan,

though not an expert in redhat, i'll try to direct you in a valid direction.
first, as i see you have already tryed to install geos before, i'd
suggest you to uninstall it:

geos related rpm you have installed, uninstall using rpm (check how to
in rpm manuals).

go to the geos source directory of each version you ever tryed to
install from sources on your current system and run: make uninstall.

then, i'd suggest you to use the procedure described at
http://nccoos.org/Members/cbc/how-i-installed-postgis, at least for the
geos part there.
you may also build geos from sources on your system, but then you may
need additional tools and packages. see eventual error message for
completing the missing files. i'd suggest you search for and install the
rpms that contain this files, and not just the source packages themselves.

i know this message is very schematic, but please use your understanding
and creativity to fill the evident gaps in my knowledge.

good luck,


Johan V wrote:
> I hope you know the solution to this problems, I'm not a linux expert
> like you maybe already noticed, but if you can tell me what I'm doing
> wrong that would be great
> Thx,
> Johan
> 2006/5/18, Johan V <jvhoppli at gmail.com>:
>> If i run ./autogen.sh (after doing a chmod +775 autogen.sh) i get
>> : bad interpreter: No such file or directory
>> If i look at this shell script and i try to execute the command one by
>> one, than i get:
>> [root at 192 geos]# uname -s
>> Linux
>> [root at 192 geos]# autoheader
>> ' is already registered with AC_CONFIG_FILES.
>> autoconf/status.m4:844: AC_CONFIG_FILES is expanded from...
>> configure.in:271: the top level
>> autom4te: /usr/bin/m4 failed with exit status: 1
>> autoheader: /usr/bin/autom4te failed with exit status: 1
>> [root at 192 geos]# aclocal -I macros
>> [root at 192 geos]# libtoolize --force --copy
>> [root at 192 geos]# automake --add-missing --copy
>> configure.in:31: `automake requires `AM_CONFIG_HEADER', not
>> configure.in: installing `./mkinstalldirs'
>> configure.in: installing `./missing'
>> aclocal.m4:4665: installing `./py-compile'
>> capi/Makefile.am: installing `./depcomp'
>> configure.in:32: required file `source/headers/config.h.in' not found
>> 2006/5/18, strk at refractions.net <strk at refractions.net>:
>> > On Thu, May 18, 2006 at 02:31:42PM +0200, Johan V wrote:
>> > > I downloaded the latest snapshot from the website (the tar.bz file),
>> > > so not with the cvs commando. So now, I tried to do it with cvs (via
>> > > another person's internet connection, because i'm behind a proxy
>> > > server, and don't now how to configure cvs correctly), but in de
>> > > directory geos there is no configure file nor a Makefile, only an
>> > > configure.in and a Makefile.am, and neither are those files in the
>> > > source subdirectory (only config.log and Makefile.am and
>> Makefile.vc).
>> > > Is it possible to put the latest snapshot as a tar.bz file on the
>> > > website please.
>> >
>> > Run ./autogen.sh in your working directory.
>> >
>> > --strk;
>> > _______________________________________________
>> > geos-devel mailing list
>> > geos-devel at geos.refractions.net
>> > http://geos.refractions.net/mailman/listinfo/geos-devel
>> >
> _______________________________________________
> geos-devel mailing list
> geos-devel at geos.refractions.net
> http://geos.refractions.net/mailman/listinfo/geos-devel

More information about the geos-devel mailing list