[geos-devel] 3.2.0 Preparations - Failed under MingW

Obe, Regina robe.dnd at cityofboston.gov
Thu May 28 08:20:35 EDT 2009

Geos trunk doesn't compile for me under MingW. Haven't tried under VS
2008 yet.

I haven't done a clean checkout so will try that next, but this is what
I get under MingW, after doing an sh autogen.sh (maybe I need to upgrade
my auto conf again)

$ sh autogen.sh
* Running /mingw/bin/libtoolize (2.2.4)
\tOPTIONS = --force --copy
libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `macros'.
libtoolize: copying file `macros/libtool.m4'
libtoolize: copying file `macros/ltoptions.m4'
libtoolize: copying file `macros/ltsugar.m4'
libtoolize: copying file `macros/ltversion.m4'
libtoolize: copying file `macros/lt~obsolete.m4'
* Running /bin/aclocal (1.8.2)
/usr/share/aclocal/autoopts.m4:22: warning: underquoted definition of
  run info '(automake)Extending aclocal'
  or see
* Running /bin/autoheader (2.59)
* Running /bin/automake (1.8.2)
\tOPTIONS = --add-missing --copy
configure.in:10: installing `./config.guess'
configure.in:10: installing `./config.sub'
* Running /bin/autoconf (2.59)
Now you are ready to run './configure'

and then ./configure

-- make works for a while and then fails with below

libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I. -I../../../source/headers
-I../../../source/headers/geos -I../../../source/headers -g -O2
-DGEOS_INLINE -pedantic -Wall -ansi -Wno-long-long -ffloat-store -MT
SnapIfNeededOverlayOp.lo -MD -MP -MF .deps/SnapIfNeededOverlayOp.Tpo -c
snap/SnapIfNeededOverlayOp.cpp  -DDLL_EXPORT -DPIC -o
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I. -I../../../source/headers
-I../../../source/headers/geos -I../../../source/headers -g -O2
-DGEOS_INLINE -pedantic -Wall -ansi -Wno-long-long -ffloat-store -MT
SnapIfNeededOverlayOp.lo -MD -MP -MF .deps/SnapIfNeededOverlayOp.Tpo -c
snap/SnapIfNeededOverlayOp.cpp -o SnapIfNeededOverlayOp.o >/dev/null
make[4]: *** No rule to make target `FuzzyPointLocator.cpp', needed by
`FuzzyPointLocator.lo'.  Stop.
make[4]: Leaving directory
make[3]: *** [install-recursive] Error 1
make[3]: Leaving directory
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/D/SVNProjects/geos/trunk/source/operation'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/D/SVNProjects/geos/trunk/source'
make: *** [install-recursive] Error 1 


-----Original Message-----
From: geos-devel-bounces at lists.osgeo.org
[mailto:geos-devel-bounces at lists.osgeo.org] On Behalf Of Paul Ramsey
Sent: Wednesday, May 27, 2009 3:27 PM
To: GEOS Development List
Subject: [geos-devel] 3.2.0 Preparations

I have triaged most of the bugs in the tracker now, and I think we  
have a reasonable working set to examine and either fix or defer now  
under the 3.2 milestone. Once that list has been worked, we can move  
to an RC1 release.



Paul Ramsey
OpenGeo - http://opengeo.org
PostGIS topical ointment. Cures slow maps.

geos-devel mailing list
geos-devel at lists.osgeo.org
The substance of this message, including any attachments, may be
confidential, legally privileged and/or exempt from disclosure
pursuant to Massachusetts law. It is intended
solely for the addressee. If you received this in error, please
contact the sender and delete the material from any computer.

More information about the geos-devel mailing list