[geos-devel] 3.0.

Obe, Regina robe.dnd at cityofboston.gov
Fri May 29 09:37:54 EDT 2009

I'm pretty sure I did that before, but tried again followed by
make clean

and still same error. 
My autogen.sh call produces this

$ sh autogen.sh
Running aclocal -I macros
/usr/share/aclocal/autoopts.m4:22: warning: underquoted definition of
  run info '(automake)Extending aclocal'
  or see
Running autoheader
Running libtoolize
libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: You should add the contents of the following files to
libtoolize:   `/c/mingw/share/aclocal/libtool.m4'
libtoolize:   `/c/mingw/share/aclocal/ltoptions.m4'
libtoolize:   `/c/mingw/share/aclocal/ltversion.m4'
libtoolize:   `/c/mingw/share/aclocal/ltsugar.m4'
libtoolize:   `/c/mingw/share/aclocal/lt~obsolete.m4'
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.in
libtoolize: rerunning libtoolize, to keep the correct libtool macros
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
Running automake
configure.in:6: installing `./config.guess'
configure.in:6: installing `./config.sub'
Running autoconf
Now you are ready to run './configure'

What is puzzling to me is why geos trunk compiles fine (its when I do
make check that I run into dupe includes with that one).  Which version
of libtool does 3.0 branch require? Mine gives this (though that CDPATH
thing is very troubling which makes me think I have a mess of libtool
versions) and I better look at that aclocal.m4 as the error and warning
suggests if only I understood what all that stuff means.

libtool --version
./libtool: CDPATH: command not found
ltmain.sh (GNU libtool) 2.2.4
Written by Gordon Matzigkeit <gord at gnu.ai.mit.edu>, 1996

-- make gives
Making all in source
make[1]: Entering directory `/D/SVNProjects/geos/3.0/source'
Making all in algorithm
make[2]: Entering directory `/D/SVNProjects/geos/3.0/source/algorithm'
if /bin/sh ../../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I.
ce/headers -I../../source/headers/geos -I../../source/headers     -g -O2
INLINE -Wall -ansi -pedantic -Wno-long-long -MT CGAlgorithms.lo -MD -MP
-MF ".de
ps/CGAlgorithms.Tpo" -c -o CGAlgorithms.lo CGAlgorithms.cpp; \
then mv -f ".deps/CGAlgorithms.Tpo" ".deps/CGAlgorithms.Plo"; else rm -f
CGAlgorithms.Tpo"; exit 1; fi
../../libtool: CDPATH: command not found
../../libtool: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.4
libtool: and run autoconf again.
make[2]: *** [CGAlgorithms.lo] Error 1
make[2]: Leaving directory `/D/SVNProjects/geos/3.0/source/algorithm'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/D/SVNProjects/geos/3.0/source'
make: *** [all-recursive] Error 1

-----Original Message-----
From: geos-devel-bounces at lists.osgeo.org
[mailto:geos-devel-bounces at lists.osgeo.org] On Behalf Of Mateusz Loskot
Sent: Friday, May 29, 2009 6:08 AM
To: GEOS Development List
Subject: Re: [geos-devel] 3.0.

Obe, Regina wrote:
  > Windows MingW is a sadder story -- I suppose it could be a similar
> thing, but make clean didn't help.  Trying to compile geos 3.0 on
> MingW - (but this could be my MingW is just a mess) (though why it
> works compiling the new geos beats me (except for make check)).
> Seems something wrong with my libtool?


You may try to run ./autogen.sh first, and then run ./configure.

I don't know if it will help MinGW, but it may help to solve autotools
issues by generating scripts specific for your environment.

Best regards,
Mateusz Loskot, http://mateusz.loskot.net
geos-devel mailing list
geos-devel at lists.osgeo.org
The substance of this message, including any attachments, may be
confidential, legally privileged and/or exempt from disclosure
pursuant to Massachusetts law. It is intended
solely for the addressee. If you received this in error, please
contact the sender and delete the material from any computer.

More information about the geos-devel mailing list