[geos-devel] Ask for help on building static library for GEOS on armv7 & armv7s architecture

Greg Troxel gdt at ir.bbn.com
Thu Oct 17 05:29:12 PDT 2013

kissv <kissv.eri at gmail.com> writes:

> I have downloaded the GEOS package(version 3.2.2) from the website
> http://trac.osgeo.org/geos/, but i was failed to build the static
> library on armv7 & armv7s by using the "configure" and "make" tool.

I think you mean "I tried to cross-build geos for arm on an amd64
machine", not that you "failed to build it **on** arm.  Please be far
more specific about what you actually did.

> The command I used is listed as follow:
> $ ./configure --host=armv7-apple-darwin
> $ make
> $ sudo make install

This doesn't make sense - if you are crossbuilding you should be
installing into an alternate DESTDIR, not the build system root.

Please explain what other programs you successfully built and ran using
this cross toolchain before you tried geos :-)   Please explain where
your cross toolchain is and how you built it or got it.

> however, when I was checking the library file, I found it is x86_64
> architecture. Since I have not used the "configure" and "make" tool
> before, I must have done something wrong in the process.

It would help to post your entire build log.  It's quite possible that
there are makefile bugs where the cross tools are not used when they
should be.  But basically you'll probably have to debug this yourself.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/geos-devel/attachments/20131017/81d2816f/attachment.pgp>

More information about the geos-devel mailing list