[GRASS5] fifos not created

Eric G . Miller egm2 at jps.net
Mon Feb 5 01:14:36 EST 2001

On Sun, Feb 04, 2001 at 09:40:32PM -0800, Jeshua Lacock wrote:
> OK, So I downloaded beta 11 and deleted the old, did a "make
> distclean" and so on.  And  after it compiles I tried to start a
> monitor and I get the message;
>   GRASS 5.0beta11 > d.mon start=x0 Sorry,
>   </usr/local/grass5/dev/fifo.1a> not available Have GRASS
>   adminstrator check etc/monitorcap file Can't stat
>   /usr/local/grass5/dev/fifo.1a Problem selecting x0. Will try once
>   more Can't stat /usr/local/grass5/dev/fifo.1a
> So I tried to inspect the fifo and found that there is no dev
> directory.  Instead there is a dev script.  I tired moving the script
> and running it and it creates the fifo's but then I still get the same
> message.
> It seems odd to me.  Beta 11 pre2 did not do this.
> The only difference between this build and pre2 is one there are new
> sources I downloaded today and two I am now running Xfree86 4.02 with
> the Aqua patch, but I do not suspect two as being the problem.

Something got puckered, not sure if it's fixed yet in CVS, but it has
something to do with the README.ipc thingy.  Anyway,

#! /bin/sh
for i in 1 2 3 4 5 6 7 8 9 10 ; do 
	mkfifo -m 0666 "fifo.""$i""a"
	mkfifo -m 0666 "fifo.""$i""b"

If you don't have mkfifo, use 'mknod -m 0666 "fifo.""$i""a" p'

You could also try running ./configure --with-fifo explicitly...

Eric G. Miller <egm2 at jps.net>

If you want to unsubscribe from GRASS Development Team mailing list write to:
minordomo at geog.uni-hannover.de with
subject 'unsubscribe grass5'

More information about the grass-dev mailing list