[GRASS5] Monitor Bug? (Mac OS X)

jeshua jeshua at SierraMaps.com
Fri Jul 6 18:31:23 EDT 2001

Greetings all,

First off I would like to mention that I now have Grass running in  
"rootless XWindows mode" in Mac OS X, complete with drop shadows and 
all - for a screen shot  point your browser to: 
http//OpenOSX.com/grass.  Very cool!  I am going to install a window 
manager next...

I have been testing Grass5 pre1's GUI and I have uncovered an (apparent) 
bug, both in the new rootless and tried and true full screen mode.  I 
started a monitor, choose "Quit", with the option "save config", and hit 
"OK".  The GUI will no longer start for this user, I tried deleting the 
.grassrc5 file and still no go.

When I launch grass5, the location chooser works, then the menu bar 
appears and states that it is "Loading...", I am prompted to position 
the monitor location, after I click I get the error (I created a new 
user and all is well - with the new user):

Error in startup script: Warning: locale not supported by C library, 
locale unchanged
     while executing
"exec xterm -geometry 40x5 -e d.mon start=$monitor"
     (procedure "start_monitor" line 17)
     invoked from within
"start_monitor $name"
     (procedure "start_monitors" line 5)
     invoked from within
     (file "/usr/local/grass5/tcltkgrass/main/gui.tcl" line 1897)
     invoked from within
"source $env(TCLTKGRASSBASE)/main/gui.tcl"
     (file "/usr/local/grass5/bin/tcltkgrass" line 17)

I am pretty sure the problem has to do with (re)creating the Monitor.  
Any idea how to zap the "preference" that starts the monitor?


Jeshua Lacock                                http://OpenOSX.com
Cartographer/Owner                    http://SierraMaps.com
Phone: (760) 935-4481            http://3dTopoMaps.com

More information about the grass-dev mailing list