[GRASS5] Monitor Bug? (Mac OS X)

Eric G. Miller egm2 at jps.net
Fri Jul 6 21:28:19 EDT 2001

On Fri, Jul 06, 2001 at 03:31:23PM -0700, jeshua wrote:
> I have been testing Grass5 pre1's GUI and I have uncovered an (apparent) 
> bug, both in the new rootless and tried and true full screen mode.  I 
> started a monitor, choose "Quit", with the option "save config", and hit 
> "OK".  The GUI will no longer start for this user, I tried deleting the 
> .grassrc5 file and still no go.

The tcltkgrass GUI has its own resource configuration file ~/.tcltkgrass

> When I launch grass5, the location chooser works, then the menu bar 
> appears and states that it is "Loading...", I am prompted to position 
> the monitor location, after I click I get the error (I created a new 
> user and all is well - with the new user):
> Error in startup script: Warning: locale not supported by C library, 
> locale unchanged
>      while executing

Does "xterm" work otherwise?  Seems the problem is with xterm not liking
the locale setting. 

> I am pretty sure the problem has to do with (re)creating the Monitor.  
> Any idea how to zap the "preference" that starts the monitor?

Yes, but it looks like it's with the xterm and your locale setting.
Looks like using "xterm" is pretty hard-wired into tcltkgrass.  It
should probably be using $TERM first.

Eric G. Miller <egm2 at jps.net>

More information about the grass-dev mailing list