[GRASS5] LD_LIBRARY_PATH and display support on solaris 8

Eric G. Miller egm2 at jps.net
Fri Oct 19 01:06:25 EDT 2001

On Thu, 18 Oct 2001 21:06:17 -0700, Hal Mueller <hal at seanet.com> wrote:

> The key is that if   --with-zlib-libs=DIR is specified to 
> "configure", then that directory has to end up in the 
> LD_LIBRARY_PATH.  I don't know where in the build tree that change 
> should be made, however.

I don't know how the runtime linker works on Solaris, but it should
probably already have libz somewhere in it's path.  On Linux, it
used to be there was an ld.so configuration file, but that's even
obsoleted these days.  To my mind, runtime dependencies outside the
control of GRASS would be difficult to handle for all of the
target platforms.  Perhaps another Solaris user can comment further.

> I also ran into the problem of the display/d.mon stuff getting built 
> with inconsistent references to sockets and fifos.  Specified 
> --with-fifo and everything worked fine.  As someone else had noted, 
> the compile goes fine without saying --with-fifo; it's only at 
> runtime that the problem arises.

There have been some recent changes with the socket handling.  Could
you elaborate what the problems are?  Sockets are now created in
/tmp/grass-$USER/, and it's my understanding that Solaris uses a
ramdisk for /tmp.  Could there be some problem creating sockets
there?  I shouldn't think so...?  Perhaps there's a problem with
the username lookup?  I was trying to find a solution that worked
for everyone (considering network file systems).  

You can get inconsistent builds if you specify one or the other of
"--with-fifo" or "--with-socket", reconfigure with the other, and 
rebuild without having done a full "distclean"...

Eric G. Miller <egm2 at jps.net>

More information about the grass-dev mailing list