[GRASS5] difficulties with r.proj

Eric G. Miller egm2 at jps.net
Mon Oct 29 10:49:28 EST 2001

On Mon, 29 Oct 2001 10:31:37 -0500, Carl Worth <cworth at east.isi.edu> wrote:

> I tried to update to the latest cvs, but I didn't see any
> improvement. I updated to the head of the tree using "cvs update -Ad".
> Do I actually want to be on a branch instead?

You want to be using the tagged branch "releasebranch_11_april_2001_5_0_0"
> I tried to use g.setproj to fix things but it croaked:
> 	Would you still like to change some of the parameters (y/n) [n] y
> 	Do you want to specify a map datum for this location?(y/n) [n] y
> 	Please specify datum name
> 	Enter 'list' for the list of available datums
> 	Hit RETURN to cancel request
> 	>nad27
> 	ERROR: invalid input ellipsoid
> The significant thing to notice here is that it never printed the
> current ellipsoid, nor did it prompt for me to change the ellipsoid.

It should have prompted for the ellipsoid before prompting for the
datum (actually, it should prompt for one or the other, but that's
not how it is currently written).
> By manually creating a location and comparing the PROJ_INFO files I
> could see that many parameters were missing from the one created by
> r.in.gdal. And worse, it had "ellps: clrk66" rather than "ellps:
> clark66". I don't know who's fault that was. But after I changed that
> manually, I was able to get g.setproj to straighten things out for
> me.

No. "clrk66" is correct.  Don't ask me why...

> So, it looks like g.setproj needs to be fixed to prompt to change the
> ellipsoid if the current one is invalid.
> Anyway, I'm up and running now, (except for the CVS issue), so thanks
> for the help.

Perhaps you've been using the main branch, which is way behind the
tagged branch above.  Changing that should make a significant
difference in all kinds of programs.  Perhaps that needs to be
publicized on the web pages better?

Eric G. Miller <egm2 at jps.net>

More information about the grass-dev mailing list