[GRASS5] Problems compiling tk.

christian tiso 977it at antigone.ing.unitn.it
Thu Dec 12 05:47:20 EST 2002

Hi, I'm Christian Tiso, a student that works with Riccardo Rigon in his  
Studio. I phoned you today because I'm desperate! Since 1 month I've  
tryed to compile grass on Macos X but unsuccesfully. I'm still in the  
./configure step because I can't find the right tk.h file. I've tryed  
to compile the tk source but every version I downloaded (8.4.1; 8.3.5;  
8.3.0; 8.2; 8.1; 8.0) gaves me a different error after the configure,  
in the make step. Every version has many different directory: macosx,  
generic, unix ecc..The macos directory doesnt have the configure file,  
so if you want to compile it you need code warrior (it is written in  
the readme file) which I have to buy, or you can use the Makefile  
alredy availiable for the macosx, but it doesnt work! The unix  
directory has the configure file, but in the make step of every version  
i found a different problem. I'm not an expert but I've compiled png,  
gd, tiff, zlib, jpg, so I thin I know how to compile under macosx. (I  
compiled and installed grass on linux mandrake without problems). I'll  
send you all the errors messages, but I think that it is better that  
someone gives me the right addres where to download a tk (and tcl to)  
version for macosx with all the step to compile and install it. I've  
tryied also with the packages for macosx in the apple site, but the  
configure with grass doesn't work.

 >Configure error configuring grass:
checking whether to use Tcl/Tk... yes
checking for location of Tcl/Tk includes...
checking for tcl.h... yes
checking for tk.h... no
configure: error: *** Unable to locate Tk includes.

So, I've tried to compile tcltk:

 >Make error with tk8.4.1as I typed in the macosx directory "make"  
(without configure, don't have configure file):
lot of things then...
cpp-precomp: warning: errors during smart preprocessing, retrying in  
basic mode
<built-in>:1:1: no macro name given in #define directive
...failed CompileC /Users/christian/Documents/programmi/pacchetti  
TkStubLibrary.build/Objects-normal/ppc/tkStubLib.o ...
make: *** [develop] Error 1
[timonchiotwin:pacchetti Xgrass/tk/macosx] root#

 >Configure error with tk8.4.1as I typed in the unix directory  
checking for Tcl configuration... found  
checking for existence of  
Xgrass/tcl8.4.1/unix/tclConfig.sh... loading
./configure: /Users/christian/Documents/programmi/pacchetti: No such  
file or directory
[timonchiotwin:pacchetti Xgrass/tk8.4.1/unix] root#

 >Make error with tcl8.4.1as I typed in the unix directory make (after  
./configure that worked):
[timonchiotwin:pacchetti Xgrass/tcl8.4.1/unix] root# make
make: *** No rule to make target  
`/Users/christian/Documents/programmi/pacchetti', needed by `Makefile'.  
[timonchiotwin:pacchetti Xgrass/tcl8.4.1/unix] root#

I have a list of a lot of others similar errors with previous versions  
till the tcl/tk8.0 if you want I'll send you, but let's start with  
those one!
Thank you
Christian tiso

More information about the grass-dev mailing list