[GRASS5] v.in.shape missing some polygons

David D Gray ddgray at armadce.demon.co.uk
Sun Feb 24 21:20:09 EST 2002

Gualter Barbas Baptista wrote:

> When I import shapefiles using v.in.shape almost everything goes ok, 
> except for some polygons, that show up the lines, but have no values, 
> which means that when I convert the vector file to raster there is 
> nothing. I tried changing the colinearity tolerance and the snap 
> distance, but the result is the same.
> I tried exporting one of these images back as a E00 and the polygons 
> that didn't show up had a value of zero. I changed manually the values 
> to 1 and re-exported to shapefile, imported in GRASS, etc. and I got the 
> same result.
> Is this some known bug or am I doing something wrong?
> Thanks,
> Gualter


It is a known bug. It happens when a polygon is imported after all the 
surounding polygons have been imported. This was originally a `feature' 
to try and get round the annoying frequency with which (at least older 
versions of) ArcView generated multiple copies of the same polygon, 
usually simple island polygons. Unfortunately it had this side-effect 
for some cell-like polygons, ie those with many neighbours.

The next release of v.in.shape should be free of this.


More information about the grass-dev mailing list