[GRASS5] Problem compiling Grass51

Bob Covill bcovill at tekmap.ns.ca
Tue Apr 29 10:26:42 EDT 2003

Markus Neteler wrote:
> On Tue, Apr 29, 2003 at 10:36:06AM -0300, Bob Covill wrote:
>>I grabbed the latest CVS versios of grass and grass51 this morning and 
>>am having problems building grass51.
>>I have updated and rebuilt grass50, but grass51 does not want to build. 
>>I get the following error about the PROJ library.
>>make[2]: *** No rule to make target `-lproj', needed by 
>>`OBJ.i686-pc-linux-gnu/b_w_line.o'.  Stop.
>>make[2]: Leaving directory `/home/covill/GRASS_DIST/grass51/display/d.where'
>>make[1]: *** [subdirs] Error 1
>>make[1]: Leaving directory `/home/covill/GRASS_DIST/grass51/display'
>>make: *** [default] Error 1
>>If I jump ahead and try and build another PROJ dependant program such as 
>>g.region I get the same error.
>>The PROJ test passes in configure.
>>Any idea what the problem is?
> Bob,
> could you run
> #fetch an updated file:
> cvs up include/Make
> #again:
> configure ....
> make
> ? I have tried to fix this problem some hours ago.
> Markus


That did not work. I tried updating (grass51), and it still failed. To 
be completely sure, I deleted grass51 and then checked it out from scratch.

Still the same error.

Any more ideas?

Bob Covill

Tekmap Consulting
P.O. Box 2016
Fall River, N.S.
B2T 1K6

E-Mail: bcovill at tekmap.ns.ca
Phone: 902-860-1496
Fax: 902-860-1498

More information about the grass-dev mailing list