[GRASS5] Problem compiling Grass51

Markus Neteler neteler at itc.it
Tue Apr 29 10:09:34 EDT 2003

On Tue, Apr 29, 2003 at 10:36:06AM -0300, Bob Covill wrote:
> Hello,
> I grabbed the latest CVS versios of grass and grass51 this morning and 
> am having problems building grass51.
> I have updated and rebuilt grass50, but grass51 does not want to build. 
> I get the following error about the PROJ library.
> make[2]: *** No rule to make target `-lproj', needed by 
> `OBJ.i686-pc-linux-gnu/b_w_line.o'.  Stop.
> make[2]: Leaving directory `/home/covill/GRASS_DIST/grass51/display/d.where'
> make[1]: *** [subdirs] Error 1
> make[1]: Leaving directory `/home/covill/GRASS_DIST/grass51/display'
> make: *** [default] Error 1
> If I jump ahead and try and build another PROJ dependant program such as 
> g.region I get the same error.
> The PROJ test passes in configure.
> Any idea what the problem is?


could you run

#fetch an updated file:
cvs up include/Make

configure ....

? I have tried to fix this problem some hours ago.


More information about the grass-dev mailing list