[GRASS5] grass 5.0.2 configure fails on RedHat 9

ametts2 at mindspring.com ametts2 at mindspring.com
Sun Jun 1 21:12:22 EDT 2003

I'm attempting a compile of grass 5.0.2 on RedHat 9.  When I run configure, the process decides it's okay to compile with TCL/TK, but then it fails to find tk.h.

tk.h is in /usr/include, permissioned to be readable by all users on my system.  tcl.h is also in this directory, and configure has no trouble at all with this file.

I tried commmenting out the check for this file in configure itself -- just to get me past this (essentially I changed the if-then-else to a "always do the then part", to avoid skipping any important logic).

This got me past the include file failure, but then configure fails to determine the Tk version (see below).

Can someone help me get past this?  Many thanks in advance!

Allan Metts -- Atlanta

checking whether to use Tcl/Tk... yes
checking for location of Tcl/Tk includes...
checking for tcl.h... yes
checking for tk.h... yes  <-- !!! I hacked configure here !!!
checking Tcl version... 8.3
checking Tk version... configure: error: *** Could not determine Tk version.

More information about the grass-dev mailing list