[GRASS5] grass 5.0.2 configure fails on RedHat 9

Glynn Clements glynn.clements at virgin.net
Tue Jun 3 06:26:23 EDT 2003

ametts2 at mindspring.com wrote:

> I'm attempting a compile of grass 5.0.2 on RedHat 9. When I run
> configure, the process decides it's okay to compile with TCL/TK, but
> then it fails to find tk.h.
> tk.h is in /usr/include, permissioned to be readable by all users on
> my system. tcl.h is also in this directory, and configure has no
> trouble at all with this file.

The check runs the C preprocessor on a test program which does
"#include <tk.h>"; if the preprocessor generates any messages (whether
warnings or errors), the check fails.

To determine why the check failed, look in the config.log file,
starting with the line:

	configure:8133: checking for tk.h

As Tk requires X, any problems with the X headers will usually cause
the tk.h check to fail.

> I tried commmenting out the check for this file in configure itself --
> just to get me past this (essentially I changed the if-then-else to a
> "always do the then part", to avoid skipping any important logic).
> This got me past the include file failure, but then configure fails to
> determine the Tk version (see below).

If the tk.h check failed, the version check will fail for same
reasons. Again, see config.log.

Glynn Clements <glynn.clements at virgin.net>

More information about the grass-dev mailing list