[GRASS5] d.legend and d.out.png

Moritz Lennert mlennert at club.worldonline.be
Thu Aug 26 12:39:09 EDT 2004

>> > In retrospect, I suspect that it is actually an issue with the form
>> > library feeding data to the etc/form/form program. I can't build
>> > that, as I don't have Tcl/Tk 8.4, so I can't really provide any more
>> > insight.
>> I actually have the same problem with Debian and GRASS compiled with
>> tcltk 8.3 (although 8.4 is also on the system).
> I am using the same setup (deb/testing) ..
>> When I use d.m, it works once and the second time I get (after two
>> clicks on the map):
>> child killed: write on pipe with no readers
>>     while executing
>> "exec d.what.vect map=communes >@stdout 2>@stdout"
>>     ("eval" body line 1)
>>     invoked from within
>> "eval "exec $cmd >@stdout 2>@stdout""
>>     (procedure "Dm::execute" line 12)
>>     invoked from within
> I got this to happen once (error in a pop up-Tcl window), but now I
> can't trigger it doing the same action.
>> When I try from the command line after this, the command just exits
>> silently after the second click.
> I'v seen this too, but can't trigger it now. Any chance of running the
> command line version through a debugger?
> CFLAGS="-ggdb -Wall" ./configure \
> ...
> make
> GRASS:~> gdb $GISBASE/etc/bin/cmd/d.what.vect

I haven't had the time to recompile with -ggdb, but my version was
compiled with -g. So I ran d.what.vect through gdb and behold: it works
like a charm !
To make it clear:

I run d.what.vect once: no problem, I quit.
I run it again: no reaction on first click, command terminates on the
second click.
I run gdb $GISBASE/etc/bin/cmd/d.what.vect, then "run" and it works
perfectly, even rerunning it several times.

Any explanations ? Do you still want me to recompile with -ggdb ?


More information about the grass-dev mailing list