[GRASS5] d.legend and d.out.png

Glynn Clements glynn.clements at virgin.net
Thu Aug 26 15:34:05 EDT 2004

Moritz Lennert wrote:

> > I'v seen this too, but can't trigger it now. Any chance of running the
> > command line version through a debugger?
> >
> > CFLAGS="-ggdb -Wall" ./configure \
> > ...
> > make
> >
> >
> > GRASS:~> gdb $GISBASE/etc/bin/cmd/d.what.vect
> I haven't had the time to recompile with -ggdb, but my version was
> compiled with -g. So I ran d.what.vect through gdb and behold: it works
> like a charm !
> To make it clear:
> I run d.what.vect once: no problem, I quit.
> I run it again: no reaction on first click, command terminates on the
> second click.
> I run gdb $GISBASE/etc/bin/cmd/d.what.vect, then "run" and it works
> perfectly, even rerunning it several times.

So the problem goes away if you run it under gdb. So much for

If you have strace, ltrace or equivalent, you could try using those.

> Any explanations ? Do you still want me to recompile with -ggdb ?

If gdb understands your existing binary, -g is equivalent to -ggdb.

Some versions of gcc/binutils understand multiple debug formats, in
which case you can use -ggdb, -gdwarf, -gstabs etc to select a
specific format. If you just use -g, it will use the default debug
format, which is usually gdb.

Glynn Clements <glynn.clements at virgin.net>

More information about the grass-dev mailing list