[GRASS5] more GRASS 5.7 testing under MacOSX

Michael Barton michael.barton at asu.edu
Thu Jan 15 11:10:49 EST 2004

Getting ready for my class this semester, I downloaded and began 
testing GRASS 5.7 again. I am using the 20 November 2003 binaries that 
Markus has kindly made available. Some of these things may have been 
dealt with in the current CVS snapshot, but I haven't yet had the 
chance to try compiling it.

So far, I've seen a couple old bugs still in effect, and run into a new 
one. Also, given that the new version is overall quite stable and 
potentially useful, I want to add two requests.

1. Nviz still doesn't work. Trying to start it returns an error that 
nviz2.2_script can't be found (even though it is indeed located in the 
proper place). I tried to force run the script from within grass, but 
it crashed before it started with several errors. If anyone is 
interested, I can send these. I don't know if this is because Nviz 
doesn't work with 5.7 yet, or it is a bug in the startup script.

2. In the display manager, when reorganizing the different map layers, 
dragging a layer a little too far (it doesn't take much) below the 
bottom-most layer starts an endless error loop that can only be exited 
by crashing out of GRASS.

3. This may be new. d.what.vect is not functioning correctly. In normal 
mode, it is supposed to return a new tcltk monitor with information 
about fields that can be changed if needed. This does not happen. If I 
am lucky, nothing happens; if unlucky, d.what.vect crashes with a 
problem with child process error. I CAN get information about a vector 
if I select the option to display it as text in a terminal window. 
Toggling flash and exit functions seem to work fine.

4. Request. Can a menu system be made for the majority of the 
commands--as in version 5.0.x? It could be pull downs across the top 
(as in prior GRASS versions), along the side (as in ArcInfo and some 
CAD programs), or floating pallets like in GIMP. I just can remember 
ALL the commands.

5. The dialogs for the g.* (general) commands all seem to lack browse 
buttons. Can browse buttons be added?

I think this is a very good and exciting product. I am strongly 
suggesting it for the graduate students here.

Thanks very much
Michael Barton, Professor & Curator
Department of Anthropology
Arizona State University
Tempe, AZ  85287-2402

voice: 480-965-6262; fax: 480-965-7671

More information about the grass-dev mailing list