[GRASS5] r.in.gdal

John Gillette JGillette at rfmd.com
Mon Jan 26 12:55:07 EST 2004

Don't forget also the optimization trick, if you haven't
tried it already. 

CFLAGS=-g ./configure ... 

configure grass as normal and then re-compile r.in.gdal.
(I would assume you can rebuild only r.in.gdal with 

This has fixed at least 2 other user's r.in.gdal (maybe),
one of whom was running Redhat 8.0.

My theory is that for Redhat >7, optimization is breaking

Please let us know if you have tried this already or if it works.


> -----Original Message-----
> From: Bernhard Reiter [mailto:bernhard at intevation.de]
> Sent: Monday, January 26, 2004 11:56 AM
> To: grass-dev
> Subject: Re: [GRASS5] r.in.gdal
> On Mon, Jan 26, 2004 at 10:10:41AM -0600, Tom Parker wrote:
> > I'm trying to resolve the r.in.gdal segmentation fault 
> mentioned several
> > times on the mailing list over the past year. The problem 
> shows itself no
> > matter what type of raster file I try and import.
> > 
> > My sytem is redhat 9 with gdal/proj/grass all built from CVS.
> > 
> > After installing and/or building and installing several 
> versions of both
> > grass and gdal as binaries or built from source the problem 
> isn't fixed. If
> > there is a simple fix I'd love to know it or I'd be happy 
> to try and help
> > fix the problem.
> Can you build with debugging support and try 
> to see what the traceback says?
> Check: http://grass.itc.it/grassdevel.html
> for links to the "debugging" hints
> Are there any versions you didn't build yourself?
> 	Bernhard

More information about the grass-dev mailing list