[GRASS5] Re: [bug #2488] (grass) Transaction (glynn.clements@virgin.net)

Glynn Clements glynn.clements at virgin.net
Thu Jun 17 06:40:37 EDT 2004

Michael Barton wrote:

> Thanks much for responding so quickly. Here is what happens. If you  
> just want to echo a string, it works OK. If you want to use the string  
> as an argument to an option, it won't work. For example, look at  
> d.vect. In the SQL box, you can put <field>=value and it works fine (no  
> spaces). But you cannot put <field>=value and <field2>=value2. This  
> generates an error that <field> value <field2> and value2 are illegal  
> values--i.e., it treats each part of the argument as a separate entry.  
> However you can do this on the command line with sql='<field>=value and  
> <field2>=value2'.
> I ran into this trying to do a script for gdalwarp. I just hit it again  
> doing a script to make v.in.ascii read in a points file from a GUI  
> interface. To specify column definitions you need to do
> v.in.ascii .... columns='xcoord double,ycoord double,name varchar(10)'  
> or something along that line.
> This works from the command line. But in a g.parser GUI dialog,  
> anything you put into am entry box for this variable gets parsed as a  
> series of illegal entries rather than a single string argument. I've  
> tried to quote it in the script, manually when I enter it, and other  
> ways and have the same results.

First, are we talking about g.parser or G_parser()?

If the problem is with the Tcl/Tk dialogs, that's probably a bug in
G_gui(). ISTR that tcltkgrass suffers from the same problem.

Glynn Clements <glynn.clements at virgin.net>

More information about the grass-dev mailing list