[GRASS5] question about CVS

Hamish hamish_nospam at yahoo.com
Fri Sep 17 00:35:32 EDT 2004

r.univar.sh should be ok as is. As Paul noted, you can't rename stuff
(only add new and remove old) but you don't need to. Module name is
generally specified in the Makefile (scripts need renaming too).
You need to 'cvs add directory' ..

there is a problem with the last commit:
Revision 1.3, Thu Sep 16 15:54:55 2004 UTC by michael 

It reverted a fix by Glynn from 6 days ago. (hardcoded path)
Always run 'cvs update filename' to update to the latest before doing
modifications and 'cvs diff filename' to check changes before
committing. Viewing it on the web interface afterwards is a good check

These non-intuitive quirks is why a lot of people like Subversion better
(but then it has its own quirks and bugs).


> I am hoping that someone can check the CVS for me and give an
> independent opinion on something that doesn¹t look quite right from my
> end.
> I updated menu.tcl for d.m this morning and tried to update the script
> r.univar.sh so that it gets compiled by default. I successfully
> updated the script itself and associated description and html files.
> The latter was necessary as it was getting compiled as r.univar,
> confusing with the binary module r.univar. I also made a small update
> to the script. So far so good.
> However, when I tried to change the name of the script directory from
> r.univar to r.univar.sh it APPEARED to commit properly, but it seems
> to be unchanged (i.e., still /r.univar) when I look at it via the web
> based CVS page (a way to check to see if my commits have _taken¹).
> Also, when I try to update the scripts Makefile accordingly, changing
> the entry from r.univar/ to r.univar.sh/ I am getting an error and it
> won¹t commit.
> Possibly related, when I did the overhaul of d.m earlier this week, I
> also committed a script directory, within the d.m folder. However, it
> doesn¹t look as though it is there when I look at it via the web based
> CVS page.
> Could someone check to see whether
> 1. the /scripts/r.univar directory has been changed to /scripts
> r.univar.sh? 2. if the scripts Makefile has been updated, changing
> r.univar / to r.univar.sh /
> 3. If the /display/d.m/script directory is there

More information about the grass-dev mailing list