[GRASS-dev] Wingrass and TclTk

Benjamin Ducke benjamin.ducke at ufg.uni-kiel.de
Mon Oct 29 05:37:38 EDT 2007

OK, the problem is not the virtual machine or the Windows
version. It gives me the same error message on a "hardware"
What confuses me is the error message itself, which does not
seem to be related to Tcl/Tk whatsoever:

Error in startup script
child process exited abnormaly
  while executing
"exec $rc_boot/bin/g.gisenv X3D_WIDTH"
  (procedure "Nv_makeGUI" line 41)
  invoked from within
line 1024

Needless to say, setting X3D_width using g.gisenv on the
command line works just fine, but the crash persists.


Moritz Lennert wrote:
> On 26/10/07 17:38, Benjamin Ducke wrote:
>> Hmm, I get exactly the same crash when running with ActiveTcl (see
>> screenshot)
>> I did:
>> nviz elev=height
>> nviz
>> (nviz started via gis.m)
> I do not use msys for running grass under windows.
> I can launch nviz from the cmd.exe with 'nviz -q' or 'nviz
> elev=elevation.dem'. I can launch it from the Gis Manager via the File
> menu, via the nviz button in the Map Display and by typing nviz -q (or
> others) in the "shell" at the bottom of the Output window.
> ...
> Just tried via msys and everything works perfectly as well.
>  > Maybe it's because I am running this in a VMWare virtual machine
>> and/or on a Windows 2000 system.
>> I'll try on some real Win hardware and XP later.
>> Another thing: is the --with-opengl=windows option working on MSYS?
> What do you mean by "working" ? I use it and I get 'OpenGL support: yes'
> at the end of configure.
>> I'll do some more tests tomorrow. Too tired for today.
> Maybe you could try with my binaries to see if that makes any difference.
> Moritz

Benjamin Ducke, M.A.
(Archaeoinformation Science)
Institut für Ur- und Frühgeschichte
(Inst. of Prehistoric and Historic Archaeology)
Christian-Albrechts-Universität zu Kiel
Johanna-Mestorf-Straße 2-6
D 24098 Kiel

Tel.: ++49 (0)431 880-3378 / -3379
Fax : ++49 (0)431 880-7300

More information about the grass-dev mailing list