[GRASS-dev] database driver errors from wish tcltk gui on mac

William Kyngesburye woklist at kyngchaos.com
Sun Mar 15 12:24:25 EDT 2009

I just verified the problem exists.  It appears to have something to  
do with my dev setup on my Mac - installed binaries on a clean non-dev  
Mac and I do get the error.

I'll see if I can track it down.  Probably something installed on my  
dev Mac accidentally getting linked to, or a path missing somewhere.

On Mar 10, 2009, at 4:47 PM, knussear wrote:

> I'm getting the errors on the binaries I downloaded from
> http://www.kyngchaos.com/.
> So I'm running
> GRASS.app 6.4 RC3 (Leopard)
> I also downloaded and installed
> ActiveTcl 8.5 from ActiveState as recommended on the site
> X11 wise I'm running Xquartz 2.4.0 - could this be the problem?
> I needed to upgrade this for one of the RGDAL builds as I recall....
> I also tried building GRASS 6.5 as one list member says his works,  
> but that
> didn't work either.
> Michael Barton wrote:
>> I've had no problems with your binary and 8.5 aqua. But it sounds  
>> like
>> he tried to compile himself. And this requires a little tweaking.
>> Michael
>> ____________________
>> C. Michael Barton, Professor of Anthropology
>> Director of Graduate Studies
>> School of Human Evolution & Social Change
>> Center for Social Dynamics & Complexity
>> Arizona State University
>> Phone: 480-965-6262
>> Fax: 480-965-7671
>> www: <www.public.asu.edu/~cmbarton>
>> On Mar 10, 2009, at 12:19 PM, William Kyngesburye wrote:
>>> On Mar 10, 2009, at 2:00 PM, Michael Barton wrote:
>>>>> So, the correct TclTk is running...  though really, in the GUI it
>>>>> doesn't matter, the GUI can use whichever TclTk you like.  It only
>>>>> matters for NVIZ, it has a binary part that was built for the  
>>>>> TclTk
>>>>> Aqua 8.5 framework.  So this may be the wrong track.
>>>> I'm betting this is an aqua vs x11 tcltk problem. No time to go
>>>> through the steps I use to compile, but I can tell you later.
>>>> Michael
>>> Well, he did originally (offlist) try my GRASS 6.4RC3 binary + TclTk
>>> 8.5 Aqua, which is working for me.  And it appears to be using 8.5
>>> Aqua.

William Kyngesburye <kyngchaos*at*kyngchaos*dot*com>

"Those people who most want to rule people are, ipso-facto, those  
least suited to do it."

- A rule of the universe, from the HitchHiker's Guide to the Galaxy

More information about the grass-dev mailing list