[GRASS-dev] error creating a GRASS location

Markus Neteler neteler at osgeo.org
Wed Nov 4 14:56:54 EST 2009

On Wed, Nov 4, 2009 at 5:24 PM, Paolo Cavallini <cavallini at faunalia.it> wrote:
> Hi all.
> Just finished a workshop (21 people!) on qgis+grass at the sasig in
> Evora[0]. Went very well, all from a USB pen [1, 2]; people looked
> enthusiastic.
> We just had a couple of problems (which, given the range of tasks I have
> been trying, is quite good to me):
> - a space in the path prevented r.contour from running successfully

... I have tried that on Linux with 6.4.0svn (current), no problem.
Which OS did you use there? The Ubuntu 9.04 GNU/Linux on the stick?

> - the creation of a location, taking the extent from a loaded map, crashed
> systematically qgis with:
> Warning: QMetaObject::connectSlotsByName: No matching signal for
> on_btnHelp_clicked()
> terminate called after throwing an instance of 'QgsGrass::Exception'
> what():  region for current mapset is not set
> run "g.region"
> Aborted

I see the same error here:

-> set by pcav to invalid :)

Perhaps GRASS is crashing only subsequently?

> Unfortunately I cannot investigate much, as the user has left, and I cannot
> replicate it on my machine, so I'll not open a bug, I mention here just for
> the record, and in case it helps understanding a potential weakness.

Is this right:
- which GRASS version: GRASS 6.4Rc5?
- which operating system: Ubuntu 9.04 GNU/Linux?

Or did the user bring his own machine?


More information about the grass-dev mailing list