[GRASS-dev] Re: wxnviz in 65, some clarification

Michael Barton Michael.Barton at asu.edu
Sun Nov 27 10:38:44 EST 2011

I can test next week when I'm back at the office. I am trying to only compile with SnowLeopard at the moment so as to not confuse testing with any Lion issues. 

Also, is trunk up and usable again?

Michael Barton
School of Human Evolution &Social Change
Center for Social Dynamics & Complexity
Arizona State University

...Sent from my iPad

On Nov 26, 2011, at 10:00 PM, "Helena Mitasova" <hmitaso at ncsu.edu> wrote:

>> Anna,
>> thank you for backporting wxnviz, I just compiled it and it runs great, even with some highly specialized data
>> (e.g. terrestrial lidar scans at 0.01m resolution).
>> There are few things that still have issues (mostly features that never really worked in nviz and may be only Mac related)
>> General
>> - when I go from 3D view to 2D and then back to 3D I lose most of my settings
>> (viewing position, zexag, fringe size etc. - this would be OK if I could get a warning and question
>> whether I want to save my 3D viewing state before switching)
>> - similarly, when I add volume to Map layers I lose my view settings and the 3D view goes back to default
> I think I found at least part of the problem - I tried saving my settings to m.nviz.image and the command saved zexag=0 although mine is set to 0.3,
> I got 2 when I set it to 2.3. Looking at the gxw file it is also saved z-exag as integer 0. Changing it to FP should fix it.
>> <z-exag>
>>                    <value>0</value>
>>                    <min>0</min>
>>                    <max>10</max>
>>                    <original>1</original>
>>                </z-exag>
>> Volumes:
>> - change of region by g.region seems to be ignored (or I missed something), I had to restart GRASS with the new region
>> to get the 3D region for volumes right. Given that the default top, botom is 1,0, if GRASS
>> starts with the default 3D region settings volumes do not work because there is just one level.
>> - isosurfaces work with my terrestrial lidar data but the slices don't, it seems that it is due 
>> my resolution being 0.3m, when I change it to 1m I get at least some limited slicing
> I am pretty sure it is the resolution - perhaps integers cutting 0.3 to 0 somewhere. Here is my slice 
> when my res3 is set to 1 - it works perfectly and the new controls are much easier to use
> http://skagit.meas.ncsu.edu/~helena/measwork/umstead/bank1_08_24_11_DTF_eldiff_timeslice9.png
> when I set my res3 to higher resolution, the slices do not show up. 
> the image is eroding stream bank, so that is why the surface is vertical.
> Helena
>> _______________________________________________
>> grass-dev mailing list
>> grass-dev at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/grass-dev

More information about the grass-dev mailing list