[GRASS-dev] [GRASS GIS] #1619: v.krige won't load: ImportError: No module named globalvar

GRASS GIS trac at osgeo.org
Tue Jun 25 17:33:05 PDT 2013

#1619: v.krige won't load: ImportError: No module named globalvar
 Reporter:  momsen   |       Owner:  grass-dev@…              
     Type:  defect   |      Status:  new                      
 Priority:  normal   |   Milestone:  7.0.0                    
Component:  Python   |     Version:  svn-trunk                
 Keywords:  v.krige  |    Platform:  Linux                    
      Cpu:  x86-64   |  

Comment(by hamish):

 Replying to [comment:13 annakrat]:
 > another fix r56924

 great, that fixes the two greyed out buttons and the output map name
 suggestions are back.

 when I press [Plot/refresh variogram] I get the same KeyError: 'InputData'
 traceback as mentioned for devbr6, I tried adding it as "global InputData"
 the the outer scripts/v.krige.py function which calls the controller, but
 it still wasn't being exported to the list of globals read by
 wxpython/scripts/vkrige.py. (maybe I did it wrong though)

 when I press [Run] I got another traceback, but fixed that in r56925. Now
 it runs in trunk from the GUI with reasonable looking results!  (default
 params, if I start messing with the fitting I run into other problems, and
 some of the progress output is a bit garbled, but one step at a time.)

 I notice it didn't pick up 'cat' as a numeric column since the
 OnInputMapChanged() function in wx/vkrige.py has `excludeKey = True`. I'm
 not sure how often the key column will be also used as a data column, but
 if nothing else it's useful for testing, so for now I've re-enabled it in
 (* in testing spearfish's arch points using the cat column as the input I
 notice one stray bad cell value (-2.27374e-13) in the results)


Ticket URL: <https://trac.osgeo.org/grass/ticket/1619#comment:14>
GRASS GIS <http://grass.osgeo.org>

More information about the grass-dev mailing list