[GRASS-dev] Testing sample fire simulation data in GRASS 7

Vaclav Petras wenzeslaus at gmail.com
Wed Jan 1 15:25:59 PST 2014


I wanted to test sample fire simulation data (
http://grass.osgeo.org/download/sample-data/) in GRASS 7. I used the
provided script and tried one command after each other (you cannot use the
whole script because of r.spread X mon connection).

However, the r.ros command is working only partially for me:

GRASS 7.0.svn (fire_demolocation):~/... > r.ros -s model=fuel_model
moisture_1h=1hour_moisture  moisture_live=live_moisture velocity=wind_speed
direction=wind_direction slope=slope aspect=aspect elevation=elevation
ERROR: Invalid descriptor: 11

I'm in demomapset. All output maps are created (my_ros.base, my_ros.max,
...) and I can run r.spread.

It seems that the error goes from lib/raster/close.c:

$ grep -Irn "Invalid descriptor" .
./lib/raster/close.c:74:    G_fatal_error(_("Invalid descriptor: %d"), fd);
./lib/raster/close.c:107:    G_fatal_error(_("Invalid descriptor: %d"), fd);

Recently, we tried some other data on some other system and it worked
without an error.  Also in GRASS 6.4.3 it works without problems (except
for the last commands but probably just the script is confusing or
confused). My system is Ubuntu 13.10 64bit (gcc).

I don't know what to test or look for.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-dev/attachments/20140101/deeda484/attachment.html>

More information about the grass-dev mailing list