[GRASS-dev] GRASS 7.0.3 and Numpy 1.10 (or Numpy > 1.8)

Ben Hur Pintor benhur.07b at gmail.com
Thu Mar 24 05:36:36 PDT 2016

Good day to everyone.

I use GRASS for most of my work involving solar radiation modelling using
r.sun. I usually work on Ubuntu 14.04 or OSGeoLive 9.0. A few days ago, I
updated the numpy installations of my system to the latest version which is
1.10. When I ran GRASS, I encountered a warning telling me:

This module requires the Numeric/numarray or NumPy module, which could not
be imported. It probably is not installed (it's not part of the standard
Python distribution). See the Numeric Python site (http://numpy.scipy.org)
for information on downloading source or binaries.

I looked around in Google and found a solution that required me to
downgrade my numpy installation back to 1.8. It said that the subpackage
numpy.oldnumeric which is needed by GRASS is only shipped with numpy up to
version 1.8 (see:

So my questions are:
(1) Will upgrading my system numpy to 1.10 really affect the computations
(2) Will GRASS eventually support/need numpy 1.10 or is the dependency on
numpy.oldnumeric permanent?
(3) Are there any other solutions to the problem above aside from keeping
the system's numpy at 1.8?

I know that I can always use virtualenvs in order to install multiple
versions of numpy on my system so I can have 1.8 for GRASS as my main
version and have virtualenvs with later numpy versions for other purposes.

Thank you.


Ben Hur
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-dev/attachments/20160324/bab4e1de/attachment-0001.html>

More information about the grass-dev mailing list