[GRASS-dev] [GRASS GIS] #2845: Build failure with 7.0.3RC1 on Linux

GRASS GIS trac at osgeo.org
Fri Mar 25 06:50:27 PDT 2016

#2845: Build failure with 7.0.3RC1 on Linux
  Reporter:  scimmia     |      Owner:  grass-dev@…
      Type:  defect      |     Status:  closed
  Priority:  blocker     |  Milestone:  7.0.4
 Component:  Compiling   |    Version:  unspecified
Resolution:  fixed       |   Keywords:  xml, toolboxes, Makefile, svnprop,
                         |  wxGUI, releasing
       CPU:  x86-64      |   Platform:  Linux
Changes (by wenzeslaus):

 * status:  new => closed
 * resolution:   => fixed


 Replying to [comment:17 neteler]:
 > Replying to [comment:16 scimmia]:
 > > OK, new info. I was able to build from r67442 just fine. I ran a
 recursive diff to see what the difference was between the tarball and the
 svn checkout, and found that gui/wxpython/xml/menudata.xml and
 gui/wxpython/xml/module_tree_menudata.xml don't exist in SVN. Removing
 those files from the tarball lets me build.
 > I have updated the release procedure to explicitly delete these files in
 r67511, r67512.
 > Now this should no longer happen.

 Original issue solved for trunk and 7.0 branch. I'm closing the ticket.
 Change of build system as suggested by [comment:32 Glynn] is for a
 separate ticket (those who know how to formulate the problem, feel free to
 open it).

Ticket URL: <https://trac.osgeo.org/grass/ticket/2845#comment:33>
GRASS GIS <https://grass.osgeo.org>

More information about the grass-dev mailing list