[GRASS-dev] Seeking advices for image segmentation algorithms and windows compile question

Moritz Lennert mlennert at club.worldonline.be
Tue May 10 01:18:49 PDT 2016

On 10/05/16 03:40, Yang, Bo (yangb2) wrote:
> Hi Helmut and Moritz,
> Thanks for the reply and advise, here is my updates:
> 1)
>>> no error reported in former steps either, and I can see the file "
>>> grass71svn.bat " is located in the right place.
>> what is the "right place"? what is the path to the "right place"?
> According to the tutorial [0], after compile with the default setting, the grass71svn.bat should be located in " c:\osgeo4w\bin\grass71svn.bat.". I see it is there, but when I run it via cmd (or double click), it always give the error:
> '""' is not recognized as an internal or external command,
> operable program or batch file.
> Press any key to continue . . .
> 2)
>>> SET OSGEO4W_ROOT=@osgeo4w@
>> could it be that OSGEO4W_ROOT isn't defined?
>> was winGRASS also installed or eventually only compiled?
> Win GRASS was not installed yet, because in the tutorial the step of "Creating a WinGRASS Installer" was located after the step of "Compiling and Installing GRASS GIS". And the tutorial mentioned: " Do not move on to step two until you have successfully tested your new version of GRASS. "
> So I didn't install WinGRASS since my compile part didn't go through yet.

I don't know about the details in Windows, here, so I'll let Helmut help 
you with this.

> 3)
>> compare OSGEO4W_ROOT above. OSGEO4W_ROOT has to be defined, otherwise the other bat-files, which define all needed variables, and grass71.py can't be found.
> I edit the grass71svn.bat file compare with your file.
> I change line " SET OSGEO4W_ROOT=@osgeo4w@ " of the bat file to " SET OSGEO4W_ROOT=C:\osgeo4w64 " since my path is C:\OSGeo4W64\bin.
> I run the grass71svn.bat again and poped up the below error:
> libintl-8.dell missing
> libsystre-0.dll missing
> ...
> I Googled the missing dll solutions[1] and copy them from C:\OSGeo4W64\bin to C:\osgeo4w64 and run again. Then it shoed on the screen:
> ---------------------------------------------------
> Cleaning up temporary files...
> Starting GRASS GIS...
> ERROR: wxGUI requires wxPython. No module named wxversion
> ERROR: Error in GUI startup. See messages above (if any) and if necessary, please report this error to the GRASS developers.
> On systems with package manager, make sure you have the right GUI package, probably named grass-gui, installed.
> To run GRASS GIS in text mode use the -text flag.
> Exiting...
> Press any key to continue . . .
> ------------------------------------------------
> I think this time is most close to start compiled GRASS so far.

This means that either wxpython is not installed, or that wxversion is 
not in the path. It should be available in the osgeo4w installer. Check 
whether it is installed.

> 4)
>> Yes, I agree: don't worry about Lidar at this stage. You should be able
>> to just ignore these errors and run GRASS anyhow. Have you tried running
>> it after this compile?
> I found that if the compile result have errors, there are no file of
> grass71svn.bat in the path of C:\OSGeo4W64\bin. So I don't know how to
> ignore the error and run GRASS anyway because on the tutorial the
 > grass71svn.bat is needed for start GRASS.

Ok, then you have to either solve the compilation errors (maybe you can 
send us the error.log of trying to run make in one of the directories 
which failed), or disable compilation by (I think - but am no expert in 
MS Windows compilation - Helmut, can you confirm ?) erasing the line


from ./mswindows/osgeo4w/package.sh.


More information about the grass-dev mailing list